Even though it says Succeeded, its not true and even it can't verify the value which is True.

Log for REG IE10+ turn off auto updates on XXXXPC

Started: 07/04/2014 11:36:13
Finished: 07/04/2014 11:36:13
Elapsed Time: 0 second
Status: 2

Output Log

Running as: SYSTEM
Checking if registry 'HKLM\SOFTWARE\Microsoft\Internet Explorer\MAIN' value 'EnableAutoUpgrade' is equal to '1' did not succeed: (2)
Setting registry 'HKLM\SOFTWARE\Microsoft\Internet Explorer\MAIN' value 'EnableAutoUpgrade' equal to '0' succeeded

Activity Log

Checking if registry 'HKLM\SOFTWARE\Microsoft\Internet Explorer\MAIN' value 'EnableAutoUpgrade' is equal to '1'
Setting registry 'HKLM\SOFTWARE\Microsoft\Internet Explorer\MAIN' value 'EnableAutoUpgrade' equal to '0'

Debug Log

Running kbot: runkbot 364 1404437768
Validating kbot xml
Kbot xml C:\ProgramData\Dell\KACE\kbots_cache\364-1404437768_expanded.xml, Validation Success
Kbot Config Info - Start
id=364 name=REG IE10+ turn off auto updates version=1404437768 type=policy
execute disconnected=false logged_off=true
execute events
Kbot Config Info - Finish
Here is my Registry set:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\MAIN]
"Security Risk Page"="about:SecurityRisk"
"Extensions Off Page"="about:NoAdd-ons"
"Start Page"="http://go.microsoft.com/fwlink/p/?LinkId=255141"
"Local Page"="C:\\Windows\\System32\\blank.htm"
"Search Page"="http://go.microsoft.com/fwlink/?LinkId=54896"
"x86AppPath"="C:\\Program Files (x86)\\Internet Explorer\\IEXPLORE.EXE"

I want to verify the above highlighted key value and set to 0.

Also tried to run as a Administrator still no luck. Don;t know why it can't see the Value.

Answer Summary:
0 Comments   [ + ] Show Comments


Please log in to comment


From the registry file, it is apparent that this is a 64-bit Windows installation. The KACE agent runs in the 32-bit environment. That means that anything you have set to go to HLKM\SOFTWARE will get redirected automatically (by Windows itself) to the HKLM\SOFTWARE\WOW6432NODE key. In order to work around this, in your script, replace all instances of HKLM with HKLM64. This tells the KACE agent to bypass redirection and go to the real 64-bit registry location. The nice thing is, if you run the same script on a 32-bit Windows, KACE just ignores the 64 and still puts it in the correct place.
Answered 07/04/2014 by: BHC-Austin
Fourth Degree Black Belt

  • Its working with HKLM64. All good now. Thanks a lot mate.
Please log in to comment
Answer this question or Comment on this question for clarity