Hello, All.

I'm having a problem to my package. When I install the vendor msi the HKLM registries didn't drop in computer registry.

Any comments? I tried to put INSTALLLEVEL but no luck.

Answer Summary:
Add WriteRegistryValues in Installation Sequence
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1

Is it vendor msi.. Are those registries under right feature/component

Answered 02/20/2013 by: jagadeish
Red Belt

  • Yes it is Vendor MSI and also there's no HKLM registries.
    I put App Paths as part of packaging standards but it didn't write upon install.

    Yes, those registries are under right feature/component. The files are dropped but the registries are not.
  • I'm wondering why It didn't write since it is per-machine location and also maybe there's a property that needs to be set in case there are lacking properties set by the vendor.
  • Can you add those registries in seperate component and associate that component to the right feature
  • I've already done that. :/ The added component is same level to the existing components from the vendor msi.
  • I created a dummy HKLM to a new component but still the registries were not being dropped.
  • Is it happening with all registries in the msi..
  • There's no registries from vendor msi. I'm just creating app paths for the packaging standards.
  • Is your msi has WriteRegistryValues standard action in execute sequence??
  • In the Installation Execute sequence? It doesn't have.
  • jagadeish. Thank you!
Please log in to comment

Answers

0

Added WriteRegistryValues in Installation Sequence. 

Answered 02/20/2013 by: ajcbasilio
Second Degree Brown Belt

Please log in to comment
Answer this question or Comment on this question for clarity