Is there a way to capture or create a user DSN to be created on all users other than just the user installing the package?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Yes, make sure all current user registry settings are in their own feature and that feature is a sub feature of complete. If the application does not trigger the per-user registry settings when run in this way consider implementing Active Setup to create the entries.

Here is an article on Active Setup:

http://www.etlengineering.com/installer/activesetup.txt
Answered 08/30/2005 by: kkaminsk
Ninth Degree Black Belt

Please log in to comment
0
You are getting too complicated again!

All you need to do is create a SYSTEM DSN instead, as this is the equivilant of a User DSN for 'all users'.

All the entries for this DSN will be in HKLM\Software\ODBC\, especially the key \ODBC.INI\

Just add these registry keys to your MSI and this ODBC entry will be available to all users on the workstation.
Answered 08/31/2005 by: brenthunter2005
Fifth Degree Brown Belt

Please log in to comment
0
I agree with brent, create a system dsn.
Answered 08/31/2005 by: Qazmo
Orange Belt

Please log in to comment
0
@Qazmo - not alot of people ever tend to agree with me, are you sure?
Answered 08/31/2005 by: brenthunter2005
Fifth Degree Brown Belt

Please log in to comment
0
ORIGINAL: brenthunter2005

@Qazmo - not alot of people ever tend to agree with me, are you sure?


Yus[:)]
Answered 08/31/2005 by: Qazmo
Orange Belt

Please log in to comment
0
thanks for your help. I tried creating a System DSN. When logging on with an account that only has "user" perms. The application prompts you an error message indicating that a user dsn is required. When logging on with an account with admin perms. The application works fine.
Answered 08/31/2005 by: urban_diver
Orange Senior Belt

Please log in to comment
0
If you have a policy, then try setting rights to the registrykey HKLM\Software\ODBC\ODBC.INI
Answered 08/31/2005 by: sejacru
Second Degree Blue Belt

Please log in to comment
0
kkaminsk, that article worked like a charm!! Thanks!!
Answered 08/31/2005 by: urban_diver
Orange Senior Belt

Please log in to comment
Answer this question or Comment on this question for clarity