User Console Library with mobile users who's IP changes cause their IP not match last inventory and scripts fail

I've itninja's and google'd this and don't see a work around but thought I'd ask "just in case".

I have a script where we want our mobile users to come into one of our sites and hard wire which of course changes their IP from our VPN appliance to the internal DHCP.  When they do that, the Device inventory still shows their last inventoried IP so when they try to use the User Console Library they either get now "Install Now" button with a message saying there is no device with that IP in the inventory or it gets submitted then fails because some disconnected device in the inventory is still associated with their IP.

My script works great if their IP matches but if they try to run it without hard wiring, their air card speed can make it take 15 minutes to get the local upgrade files over or if they try it when they first logon their computer won't have been inventoried and we fail again.  And of course the software has some special rules where it has to be installed with XPSP3 and ADMIN Compatibility Flags which I can't set on a network share file (so I have GP set the flags) plus it can't be run silently because of all the prompts.

I have forced at an elevated prompt "C:\program files (x86)\Dell\Kace\runkbot.exe" -s 4 0 but we don't want officers to do that and I can't put that in my script if it pushes to an old IP anyhow. 

Here is a link to the software's published Windows 7 deployment guide if it helps: http://www.ecitation.nccourts.org/downloads/ecitation-windows7-installation-20160504.pdf

Thanks for any ideas!

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

There are no answers at this time

Answers

Answer this question or Comment on this question for clarity