I was able to set up a field for the tickets in our K1000 which tracks the so called "Adjusted Time".
This field (and the corresponding 4 ticket rules) tracks the actual time (in hours) a ticket was either set to "Open" or "New", i.e. in the hands
of one of our technicians. Those rules exclude non-working-hours/weekends/holidays and the time a ticket was set to "Stalled". This works beautifuly.


Despite excluding the above-mentioned circumstances, tickets are still escalating during non-working hours/weekends/holidays.

My Question:

Is there a way not to escalate during the mentioned circumstances?
Tickets set to "Open" should only escalate according to the "Adjusted Time" instead of "Time Opened".

Any ideas? Thanks for your help :-)


Answer Summary:
0 Comments   [ + ] Show Comments


Please log in to comment

Community Chosen Answer


I believe you can use the article below to limit when your escalation ticket rule runs:


Answered 10/23/2012 by: jknox
Red Belt

  • Thanks for your answer jknox.
    I don't have any custom SQL escalation rules at all.
    I'm using the standard KACE escalation functionality where you pretty much only are able to set a specific triggertime for priorities you created, i.e. "High" = 30 minutes until e-mail gets triggered, "Medium" = 2 hours and so on.

    The actual logic behind triggering the e-mails after the defined timespan does not seem to be editable or viewable at all.
    I worry I have to disable escalation all together and that I have to come up with custom rules.
    I’m really not an SQL Guru, but can someone at least confirm my suspicion?
  • You are correct, the system rules can't be modified in the way you want. You'll have to create your own custom rules that will act on your Adjusted Time. It sounds like you have some SQL experience if you have your adjusted time rules working in the way you describe. Writing the rules to send an email based on that time shouldn't be very difficult.
  • Hi chucksteel
    Thanks a lot for your answer. Still not sure how to trigger the actual e-mail. At least I know it is not possible to solve this problem with pre-defined KACE functionality.
Please log in to comment



I'm going to show  how to implement some foundational rules that you can build upon in this blog series http://www.itninja.com/blog/view/creating-true-sla-timers-in-the-kbox-helpdesk-part-1-what-you-really-want-from-your-data

One of the parts will discuss dealing with business hours, days open (e.g. weekdays) and days closed (e.g. Christmas).  You'll still need some code to deal with it but the series will show you how to use a consistent peice of SQL that all your rules can leverage.  You can update it in one place and all rules will adhere to that setting.

Until then here is a snippet of code that one could use in their update or select query if they didn't want a central place to store those settings.  This code is for a helpdesk that is open 0800h to 1800h, closed on weekends and common U.S. statutory holidays

/******* begin only during business hours ***********/
     /**/and HOUR(NOW())>=8  /* 8am or later kbox time*/
     /**/and CURTIME()<='18:00:00'  /* before 6pm Pacific */
     /**/and DAYNAME(NOW()) NOT IN ('Saturday','Sunday' /* not the weekend */
     /**/and DAYOFYEAR(NOW()) NOT IN (1,360)   /* not xmas or new year's */
     /**/and NOT(   /*not U.S. thxgiving 2 days */
     /**/   MONTHNAME(CURDATE())='November' and (
     /**/      (DAYNAME(CURDATE())='Thursday' and DAYOFMONTH(CURDATE()) IN (22,23,24,25,26,27,28)) OR
     /**/     (DAYNAME(CURDATE())='Friday' and DAYOFMONTH(CURDATE()) IN (23,24,25,26,27,28,29))
     /**/)  )  and NOT(      /* not U.S. Labor Day */
     /**/   MONTHNAME(CURDATE())='September' and DAYNAME(CURDATE())='Monday' and DAYOFMONTH(CURDATE()) IN (1,2,3,4,5,6,7) )
     /******* end only during business hours ***********
Answered 12/19/2012 by: GillySpy
Seventh Degree Black Belt

  • Thanks Gilly, really usefull!!!!
    does somebody know how to send the scalation´s notification JUST ONE TIME??
    My rule has to send a notification when a ticket is untouched in 1:30h, but it sends the notification every 1:30h, it has to send it Just one time after the first 1:30h
Please log in to comment
This content is currently hidden from public view.
Reason: Removed by user request
For more information, visit our FAQ's.

Answer this question or Comment on this question for clarity