Hi i have problems in upgrades.when i try to install the latest version it gets installed but still i could find the previous version.I created a wsi for the previous version's msi and renamed it to the latest version,made necessary changes in product details and added the previous version in the upgrades of installation expert.I am a newbie.please help me and thanks in advance
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hi Neha,

Can u check whether upgrade code for both the package is same similarly product language property .
Answered 04/01/2008 by: packengg
Orange Belt

Please log in to comment
0
thanks for the reply.the upgrade code is the same for both the packages and the productlanguage property is also same
Answered 04/01/2008 by: Neha
Senior Yellow Belt

Please log in to comment
0

In upgrade table set attribute to 260 and Set action property column value to FMUPG .

Create a Private property in property table as

SecureCustomProperties with value FMUPG. and the version of ur new upgrade package should be higher than the previous one.[/align]
Answered 04/01/2008 by: packengg
Orange Belt

Please log in to comment
0
I have tried what you said but still the old version is there.
Answered 04/02/2008 by: Neha
Senior Yellow Belt

Please log in to comment
0
Check the version min and version max value in Upgrade table. Ur package version should be higher than the previous version . version min should contain the value 0.0 and mx should contain ur upgrade package version.
Answered 04/02/2008 by: packengg
Orange Belt

Please log in to comment
0
Hi Neha,
log the install and then search the logfile for the "FindRelatedProducts" action. This is the action which actually finds an installation with a known Upgradecode.
If this looks ok, go to the "RemoveExistingProducts" action. This action actually removes an installation found by FRP.
Also make sure, that both installations take place under the same context (machine or user).
Regards, Nick
Answered 04/02/2008 by: nheim
Tenth Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity