Hi,

I have created an .mst to allow me to amend a products .msi. I have changed the relevant codes and setup the upgrade table with the correct upgrade code. I originally had it set with the max version as the latest version code and with attribute code of 256. I tested that it upgraded the old version on my test machine and everything worked fine so I have released it via SMS to about 24 pcs. It has worked fine on half of them but it has failed on the other half. The error SMS gives me for the failure is that "Another version of this product is already installed". I have since tried it with various attribute codes (0, 256,512,756) and also only with min version specified but nothing works. I don't know whyit worked for half of them but not the rest.

Can anyone tell me what the correct attribute code should be as I cant seem to find a proper answer anywhere. Also, should I enter the max or min versions or both of them? The old version is 6.2.1295 and the new one is 6.2.1582. I have had a look on a failed pc and they have version 6.2.1295 installed. I dont fancy having to go round and do a manual uninstall and install on these pc's so can someone offer me some advice?

Thanks in advance :)
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Sounds like the PackageCode differ.
What do you mean by "I have changed the relevant codes"?
How & what did you change?
Answered 12/01/2008 by: AngelD
Red Belt

Please log in to comment
0
ORIGINAL: AngelD
Sounds like the PackageCode differ.


Or rather, the same.


ORIGINAL: Sarahg
the latest version code and with attribute code of 256


Do you mean the min/max versions in the upgrade table ?
Answered 12/01/2008 by: reds4eva
Second Degree Blue Belt

Please log in to comment
0
I meant I have made sure the upgrade code was the same in both old version and new one.
Answered 12/03/2008 by: SarahG
Senior Yellow Belt

Please log in to comment
0
Correct Reds,

I was too fast when I wrote that.
Answered 12/03/2008 by: AngelD
Red Belt

Please log in to comment
0
Do they really share the same UpgradeCode?
Answered 12/06/2011 by: AngelD
Red Belt

Please log in to comment
0
No, different upgrade codes. But when i try to add an upgrade code for the reader into the pro package i get an error when trying to save that min version to upgrade must be less then to the max version
Answered 12/06/2011 by: ogeccut
Black Belt

Please log in to comment
0
First, please dont hijack threads. You question has nothing whatsoever to do with MSI's Upgrade table.

Second, if the native installer is crashing Explorer, your first port of call is surely the vendor? There's precious little anyone can do with an installer authoring tool to help.
Answered 12/08/2011 by: VBScab
Red Belt

Please log in to comment
0
ok, thanks for information. can u please send me any threads related to this issue or any threads wher i have to post this issue.
Answered 12/09/2011 by: pradeepsexy.kumar
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity