This is regrading TEMS Investigation application.

We need to apply upgrade logic to a vendor MSI.

The older package is already there in the LIVE server. But the new MSI what we have and the old MSI have the same product codes. If we change the product code of the new MSI, then it is doing the upgarde but one of the shortcuts is not functioning properly.

The other option we tried is to write a VB Script that will check the existing product code and uninstall the application. We kept this VB Script above FindRelatedProducts in Execute Immediate mode. But it is not working. It is doing the repair of the old application rather than upgarding.

Could you please help me to resolve this issue?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
VBScript? Why make it so complicated? Jeez...

Upgrades are pretty straightforward. Start your reading here http://msdn.microsoft.com/en-us/library/aa370579(VS.85).aspx. Once you have digested that, move here http://msdn.microsoft.com/en-us/library/aa372379(VS.85).aspx
Answered 03/05/2009 by: VBScab
Red Belt

Please log in to comment
0
When we try for a normal upgrade.....the shortcut is not launching properly and it is throwing error.
Answered 03/05/2009 by: rejeeshgeorge
Senior Yellow Belt

Please log in to comment
0
What does your command line look like?
What does a verbose log of the upgrade tell you? That you didn't create a log yet? :)
Answered 03/05/2009 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity