Hi,

Anyone tried uninstalling Microsoft Application Error Reporting application (dw20shared.msi).

Eventvwr shows that Removal failed.

But its getting installed even if it is already installed in the PC.

Any idea on this...

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

0

Yes pjgeutjens,

I used this APPGUID property to install this application.

I have problem in uninstallation only.

Answered 05/07/2012 by: bhagu_krish
Orange Belt

  • just a thought, but have you tried adding it to the uninstall commandline, or uninstalling using the productcode directly, instead of the MSI (if you're not already doing that)?
    • thanks pjgeutjens
      I already followed tried those.
  • thanks pjgeutjens
    I already tried those.
Please log in to comment
0

This works for Installation.

I still have problem with uninstallation

Answered 05/08/2012 by: bhagu_krish
Orange Belt

  • Have u found the solution for uninstalling?
Please log in to comment
0

have you tried running the msiexec uninstall command with appropriate logging (/L parameter)? That should provide some insight into what's going wrong

Answered 05/07/2012 by: pjgeutjens
Red Belt

Please log in to comment
0

Thanks pjgeutjens.

 

I have created log file also. It is an dll CA throws return value 3.

 

Action start 14:41:11: CADwDoSharedRefCountRemove.
MSI (s) (18:F4) [14:41:11:741]: Machine policy value 'DisableRollback' is 0
MSI (s) (18:F4) [14:41:11:741]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
Action ended 14:41:11: CADwDoSharedRefCountRemove. Return value 3.
MSI (s) (18:F4) [14:41:11:751]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (18:F4) [14:41:11:751]: No System Restore sequence number for this installation.
MSI (s) (18:F4) [14:41:11:751]: Unlocking Server
Action ended 14:41:11: INSTALL. Return value 3.

Answered 05/07/2012 by: bhagu_krish
Orange Belt

Please log in to comment
0

have a look at the last post in this discussion, might be of use to you:

http://social.msdn.microsoft.com/Forums/en-IE/vssetup/thread/fd0ccc8b-4cb0-4f4a-87fa-09bb66bee6b3

Answered 05/07/2012 by: pjgeutjens
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity