/bundles/itninjaweb/img/Breadcrumb_cap_w.png
Trying to install the WAIK in an unattended/silent mode. Does anybody know how? Normal methods do not work.
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity

Answers

0
In desperation in similar situations, I have resorted to using nonsense switch characters, in the hope that the nice developer Johnnie would prompt me with the valid set, like MSIExec does. Try 'Setup /_thisisridiculous' - the leading underscore attempts to avoid the stub taking the first character as the argument, which by chance could be valid.
Answered 02/27/2008 by: VBScab
Red Belt

Please log in to comment
0
The WAIK install is actually a MSI but when you try to use normal silent install commands, you are prompted with a dialog box stating that you must runb the install in full UI.
Answered 02/27/2008 by: rohansen
Yellow Belt

Please log in to comment
0
I presume you've tried the usual 'fix', of setting the property ISSETUPDRIVEN to 1?
Answered 02/27/2008 by: VBScab
Red Belt

Please log in to comment
0
I just tried that with the following command but with same results. Any other suggestions?

msiexec.exe /i /qb WAIK_x86.msi ISSETUPDRIVEN=1
Answered 02/27/2008 by: rohansen
Yellow Belt

Please log in to comment
0
There is only a limited number of ways this could be happening. Either a LaunchCondition is set or a Custom Action is being called to set a property. You just need to find it.

Edit
Found it for you. Create a transform and in it, take out the LaunchCondition "UILevel = 5","[String_MustHaveFullUI]"

MAKE SURE YOU FULLY TEST THE DEPLOYED APP! There has to be a reason they want full UI, I just haven';t had time to find out what yet. From a cursory glance it looks like it might simply be that they want to force the display of the EULA...
Answered 02/27/2008 by: VBScab
Red Belt

Please log in to comment
0
Worked!!! Thanks
Answered 02/27/2008 by: rohansen
Yellow Belt

Please log in to comment