So we are scratching our heads on this one, everytime we try and use the VNC icon on the k1000 it gives us the unable to run action error.  Well ironcily there is suposedly a fix on the kace FAQ but so far we have not been able to get it to work, we tried every little option on the suposed fix and it still doesnt seem to work, we tried it on IE7,IE8 and IE 9, local intranet, trusted sites etc etc.  The directions I followed i will post below so someone doesnt just paste the same thing in here again.  Any ideas on what others did to get it to work would be great!  Thanks!

 

 

When clicking on the machine action icon in the KACE K1000 Appliance Management Center to launch Remote Control or another Machine Action, you may receive the following error message:

Unable to run Machine Action.  
Please check your Microsoft Internet Explorer Security Settings.

In order to resolve this error, verify the security settings for the Trusted Sites zone in your Internet Explorer ... Tools .. Internet Options on the machine you use to browse the KACE K1000 Appliance Management Console.

INTERNET EXPLORER 6

Launch Internet Explorer 6 and navigate to:

1. Tools > Internet Options > Security
2. Select Trusted Sites Icon
-Add K1000 IP address to the zone
-Require Server Identification (Uncheck)
3. Click 'Custom Level' button
-Reset to Low or Medium Low
4. Under 'ActiveX Controls and Plugins'
-Automatic Prompting for ActiveX controls > Enable
-Download unisgned ActiveX controls > Enable
-Initialize & script ActiveX controls not marked safe for scripting > Enable
-Run ActiveX controls and plugins > Enable
5. Click 'OK'
6. Click 'Yes'
7. Click 'OK'

INTERNET EXPLORER 8

Launch Internet Explorer 8 and navigate to:

1. Tools > Internet Options > Security
2. Select Trusted Sites Icon > Sites Button
-Add K1000 IP address to the zone
-Require Server Identification (Uncheck)
-Click Close
3. Custom Level > Medium
4. ActiveX Controls Plugins
-Allow previously unused ActiveX controls > Enable
-Allow scriptlets > Enable
-Automatic Prompting for ActiveX controls > Enable
-Download unisgned ActiveX controls > Enable
-Initialize & script ActiveX controls not marked safe for scripting > Enable
-Run ActiveX controls and plugins > Enable
5. Click OK to close Security Settings Window
6. Click OK to close Internet Options Window

MACHINE ACTION SETTINGS:

1. Log into the K1000 Admin UI
2. Settings > Control Panel > General Settings
3. Scroll down to Machine Actions > Edit Mode
4. Verify the path variables to the VNC Executable on the PC
-Default is "%ProgramFiles%\\ultravnc\\vncviewer.exe" KACE_HOST_NAME [change this to reflect the actual path, if needed]
5. Click 'Set Actions' button

Note: When using Windows 7 64-bit and IE8 you must use the full path to the vncviewer.exe in the machine action settings.

Example:

"C:\\Program Files\\ultravnc\\vncviewer.exe" KACE_HOST_NAME

If your Internet Explorer settings are correct, and you continue to receive this error, also verify that the executable for the Machine Action command is in your system path. For example, if you are using the Dameware option, the path to dwrcc.exe must be in your system path for the command to launch.

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

0

I have VNC Viewer Plus, and I'm not sure if that gives me more capability, but this is the approach that I took so that I could have VNC auto-popup without even having to change IE settings, or add my kace addresses to my "Trusted Sites"

kvm://admin:@KACE_HOST_NAME.yourdomainnamehere.com

This is using the syntax found after running:

C:\Program Files (x86)\RealVNC\VNCViewerPlus\vncviewerplus.exe /?

And like most "Help" commands, it gives you the entire list of options available to you via kvm:// or cmd.exe

Answered 07/31/2015 by: AeroMIS
White Belt

Please log in to comment
0

I have VNC Viewer Plus, and I'm not sure if that gives me more capability, but this is the approach that I took so that I could have VNC auto-popup without even having to change IE settings, or add my kace addresses to my "Trusted Sites"

kvm://admin:@KACE_HOST_NAME.yourdomainnamehere.com

This is using the syntax found after running:

C:\Program Files (x86)\RealVNC\VNCViewerPlus\vncviewerplus.exe /?

And like most "Help" commands, it gives you the entire list of options available to you via kvm:// or cmd.exe

Answered 07/31/2015 by: AeroMIS
White Belt

Please log in to comment
0

One thing to double check, did you add the url your connecting to. Remember

IP, kbox, kbox.company.name are all different.

Another thing i do to test, is enable ALL the active X settings. Not safe but this way you can tell if its a config issue or not.

Answered 04/16/2012 by: dchristian
Red Belt

  • What are you refuring too when you stated "One thing to double check, did you add the url your connecting to. Remember IP, kbox, kbox.company.name are all different." Are you refuring to trusted sites?
    • Yes that is correct. Did you add all the possible websites to the trusted sites?
Please log in to comment
0

Depending on how you install UltraVNC you need to specify this following path for a 64bit OS - 

"C:\\Program Files (x86)\\ultravnc\\vncviewer.exe" KACE_HOST_NAME

or 

"C:\\Program Files (x86)\\ultravnc\\vncviewer.exe" KACE_HOST_IP

 

Did you install the Server version (UltraVNC Server Only) on the target machine and the VNCViewer version on your machine? 

When you install the Server Version, both port 5800 & 5900 will be added as an Inbound Rule on Windows Firewall. 

Same goes for Microsoft RDP - mstsc.exe /v:KACE_HOST_NAME, you still need to enable & Allow connections for Remote Desktop on the target machine. 

Answered 04/17/2012 by: Aaron Cool
Red Belt

Please log in to comment
0

aaronb09,

The settings should work. I've only seen one machine (out of MANY) that didn't work at all, and we eventually found a browser plug-in that was the culprit.  Have you tried any other Machine action, besides VNC?  Unfortunately, the error message is the same whether the problem is the IE Security Settings OR the excutable just doesn't work.  r2

Ron Colson

KACE Trainer

Answered 04/17/2012 by: ronco
Second Degree Brown Belt

  • So i figured out the cause but not sure how to fix the issue, the installer is going to the x86 folder instead of the Program Files folder, even if its a 64 bit install it still goes to the x86 folder and the script doesnt seem to be altering the install location. Here is my scipt steps from the Kbox

    On Success
    Set “HKLM\SOFTWARE\ORL\WinVNC3\Default!Password†to “hex:ec,8e,d2,e0,cd,fc,aa,1bâ€.Edit
    Set “HKLM\SOFTWARE\ORL\WinVNC3!MSLogonRequired†to “0â€.Edit
    Set “HKLM\SOFTWARE\ORL\WinVNC3!NewMSLogon†to “0â€.Edit
    Set “HKLM\SOFTWARE\ORL\WinVNC3!DisableTrayIcon†to “1â€.Edit
    Set “HKLM\SOFTWARE\ORL\WinVNC3\Default!AllowEditClients†to “0â€.Edit
    Set “HKLM\SOFTWARE\ORL\WinVNC3\Default!AllowProperties†to “0â€.Edit
    Set “HKLM\SOFTWARE\ORL\WinVNC3\Default!AllowShutdown†to “1â€.Edit
    Launch “SYS\cmd.exe†with params “/C â€mkdir “C:\Program Files\UltraVNCâ€â€œâ€.Edit
    Launch “SYS\cmd.exe†with params “/C â€copy “$(KACE_DEPENDENCY_DIR)\ultravnc.ini†“C:\Progra~1\UltraVNC\ultravnc.ini†/Y“â€.Edit
    Launch “SYS\cmd.exe†with params “/C â€copy “$(KACE_DEPENDENCY_DIR)\rc4.key†“C:\Progra~1\UltraVNC\rc4.key†/Y“â€.Edit
    Launch “$(KACE_DEPENDENCY_DIR)\UltraVNC_1.0.5.6_Setup.exe†with params “/loadinf=â€$(KACE_DEPENDENCY_DIR)\ultravnc.inf“ /verysilentâ€.Edit
    Launch “C:\Program Files\UltraVNC\MSLogonACL.exe†with params “/i /o â€C:\Program Files\UltraVNC\acl.txt“â€.Edit
Please log in to comment
0

Delete both of this scripting line - 

Launch “SYS\cmd.exe” with params “/C ”copy “$(KACE_DEPENDENCY_DIR)\rc4.key” “C:\Progra~1\UltraVNC\rc4.key” /Y“”.Edit

Launch “C:\Program Files\UltraVNC\MSLogonACL.exe” with params “/i /o ”C:\Program Files\UltraVNC\acl.txt“”.Edit

 

Did you upload the UltraVNC 1.0.5.6 setup file to the K1000? 

If you decide to use the latest version, you'll have to upload UltraVNC 1.0.9.6.2 and change the parameters for this script. - "UltraVNC_1.0.9.6.2_Setup.exe"

Answered 04/17/2012 by: Aaron Cool
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity