I have captured an installation of an app that we use at work. When install the captured MSi i get a "could not register type library file..."
on a AF20.dll under common files\ESRI folder.

suggestions online say to change the file so it doesn't register. I am unable to find that option with MSI Editor.

Any suggestions?
3 Comments   [ + ] Show Comments

Comments

  • Avoid morons that advise you to not register type libraries. Clearly, they know nothing.

    Create a Custom Action to execute RegTLib.EXE which you can download - I believe - as part of the Platform SDK (or whatever Microsoft is calling it this week).
  • Capture is not 100% reliable and as the type library has the DLL extension rather than the TLB extension, the registration method that windows installer uses is that provided by REGSVR32.exe, and usually via the selfreg table. Unfortunately, type libraries do not have a recognisable entry point for normal DLL registration to work, so having received this error message, you need to first turn off the self registration and then test whether the AF20.DLL file can be correctly registered using RegTLib.exe. Looking on my Win 7 machine, there is an instance of RegTLibV12.exe installed as part of the .NET4 framework.
  • Thanks for the suggestions guys. I will be trying them out this week. I will Keep you posted.
Please log in to comment

Answers

0
Did you try the selfreg table?
Answered 12/01/2014 by: EdT
Red Belt

Please log in to comment
0
Thank you for your interest in PACE Suite and for your questions!

It is a well-known problem of Windows Installer. According to MSDN it is strongly advised against using the TypeLib table. Please, register type libraries using the Registry table.
Launch MSI Generator and go to Settings. Select your profile at MSI Creation Options and click Edit as shown on the screenshot:


Select Registry and uncheck the TypeLib checkbox:


Click the Save button and then re-build your package:


Inform us if it does not work for you.
Answered 12/12/2014 by: pace-support
Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity