i was trying to repackage true db grid, my msi was working fine on same box, but i was able to install fine on the othe box's but getting license error while launching .chm shortcut

vinod_mukka@yahoo.co.in
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
wt do you mean by "on the same box", fresh image on the same box you took the capture ?
if it is then check if the machine name is captured anywhere in the package . do a search for the machine name in the tables.
Answered 05/11/2005 by: bheers
Second Degree Blue Belt

Please log in to comment
0
it is working on the same machine i packaged, but it is not working in the different machine, i tried very much that weather it captured machine name any where, i was unable to find. may be it is encrypted i think.
Answered 05/11/2005 by: vinod_mukka
Senior Yellow Belt

Please log in to comment
0
on a clean machine not the one its working on, install the application, then run incontrol or take a snapshot using wise or installshield then install the original source media run the application to make sure its working and capture the difference, it might help
Answered 05/11/2005 by: bheers
Second Degree Blue Belt

Please log in to comment
0
it does not work, i captured only one file and i tried adding that file to my msi, here is the error(ending part of log file)

Action 13:45:11: RemoveODBC. Removing ODBC components...
Action 13:45:11: InstallFiles. Copying new files...
InstallFiles: File: hh.dat
Directory: C:\Documents and Settings\qk604ctst03\Application Data\Microsoft\HTML Help\
Size: 8634
DEBUG: Error 2919: No cabinet specified for compressed file: hh.dat
DEBUG: Error 2835: The control ErrorIcon was not found on dialog ErrorDialog
Internal Error 2835. ErrorIcon, ErrorDialog
Internal Error 2919. hh.dat
MSI (s) (7C:A0) [13:45:17:180]: Product: True DBGrid 7.0 -- Internal Error 2919. hh.dat

Action ended 13:45:17: InstallFinalize. Return value 3.
Action 13:45:17: Rollback. Rolling back action:
Rollback: Copying new files...
Rollback: Removing ODBC components...
Rollback: Updating component registration...
Action ended 13:45:17: INSTALL. Return value 3.
Action ended 13:45:17: ExecuteAction. Return value 3.
Action start 13:45:17: Fatal_Error.
Action 13:45:17: Fatal_Error. Dialog created
Action ended 13:45:19: Fatal_Error. Return value 2.
Action ended 13:45:19: INSTALL. Return value 3.
=== Logging stopped: 5/11/2005 13:45:19 ===
MSI (c) (80:A0) [13:45:19:009]: Product: True DBGrid 7.0 -- Installation operation failed.
Answered 05/11/2005 by: vinod_mukka
Senior Yellow Belt

Please log in to comment
0
i captured initial snapshot of non working box and installed the original install and took 2nd capture, the difference in the registry i added to my msi, it is working fine now, but the problem is it is not working on any other box. registry is changing from machine to machine, how to solve this issue.
Answered 05/11/2005 by: vinod_mukka
Senior Yellow Belt

Please log in to comment
0
wt registry is it changing ? can you put it clear
if you do not put anything in detail we cannot find out where the error is
Answered 05/12/2005 by: bheers
Second Degree Blue Belt

Please log in to comment
0
[HKEY_LOCAL_MACHINE\Licenses\5A2D8B05-A285-43a3-8C7F-0FC8661D173B]
@="82bd893327f4fec8bbe7662e2bb399c24ca4"

[HKEY_LOCAL_MACHINE\Licenses\6D787A66-B43D-4e7c-AE61-DF90400171BE]
@="793cea01b2d2e4a3bbe7662e2f9b6bd96d40"

these are the registry keys which it is changing it is changing only these values, i coloured the values it is changing. the native install is installing differentvalues for each installation and also for each machine.
Answered 05/18/2005 by: vinod_mukka
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity