Hello all,

I have a vendor app (an msi) - when using a transform to specify the database server name and database instance name these entries are not passed correctly and subsequently the application cannot connect to the relevant DB.

When installing the app interactively and typing the relevant entries the information is passed successfully and the app works correctly.

I generated a couple of log files created for the scenarios mentioned above and the major difference is as follows:

No transform applied (info typed manually):

PROPERTY CHANGE: Adding SERVERNAME property. Its value is 'SOMESERVER'.

With transform applied:

PROPERTY CHANGE: Deleting SERVERNAME property. Its current value is 'SOMESERVER'.

So I guess my question is can I somehow change the transform so that the property value is not deleted but added?

Thanks

Mos
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
looks like I'll have to use a CA to delete the config files that the installation creates and then replace them with pre-configured config files then as there doesnt seem to be a way of controlling the installation correctly from the transform...probably the fault of the vendor no doubt...?
Answered 04/23/2010 by: mosquat
Orange Belt

Please log in to comment
1
- How are you deploying the package?
- Does the transform contain the property, with the appropriate value set?
- What does your command line look like?
- Might there be a property-setting Custom Action in the UI sequence which doesn't appear in the ExecuteImmediate sequence?
Answered 04/23/2010 by: VBScab
Red Belt

Please log in to comment
0
- How are you deploying the package?

At present I'm using a command prompt to kick of the installation but eventually with be using SCCM

- Does the transform contain the property, with the appropriate value set?

The transform was made using Installshield, I created a response transform and typed in the information. I also made other transforms and manually entered the information in the property table. I also specified the Property names and values on the command line (without using the transform and get the same result) - just a note here - each attempt was a seperate test in case anyone thought I merged everything into one test ;)

- What does your command line look like?

msiexec.exe /i HMT.LoginSetup.msi /qb TRANSFORMS=RPC.mst /l*v RPC-TRANSFORM-APPLIED.log

The transform settings are being applied as I have moved the shortcut to test if any settings are being applied - this is working at least...

- Might there be a property-setting Custom Action in the UI sequence which doesn't appear in the ExecuteImmediate sequence?

Will take a look at this and feed back

Thanks
Answered 04/23/2010 by: mosquat
Orange Belt

Please log in to comment
0
A nice, easy and quick test would be to run your command line without the '/qb'. If the property is being read, it should pre-populate the text box on the relevant dialog.
Answered 04/23/2010 by: VBScab
Red Belt

Please log in to comment
0
VB - I think you are spot on - there are some custom actions called "CustomTextA_SetProperty_EDIT1" (through to "4") that are only present in the installation\UI sequence.

I dont know if this is really best practice but I moved them in my transform to the Advertisement\UI sequence and also populated the property value with the servername - on first test a connection has been made to the server successfully....

Obviously a few additional tests are required here (and maybe an earbashing for the above?) but thanks for your suggestion.
Answered 04/23/2010 by: mosquat
Orange Belt

Please log in to comment
0
looks like populating the items with the servername is enough to get this to work so have moved back to installation\UI
Answered 04/23/2010 by: mosquat
Orange Belt

Please log in to comment
0
I moved them in my transform to the Advertisement\UI sequenceI generally copy them into the Execute sequence, rather than moving.
Answered 04/23/2010 by: VBScab
Red Belt

Please log in to comment
0
Thanks VBScab
Answered 04/26/2010 by: mosquat
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity