Recently I tried to install Wise Package Studio and got the following message. "The system administrator has set policies to prevent this installation".

For my particular instance it was fixed by changing a value in the registry under


Name - DisableMSI Type - REG_DWORD 0 = enable

This was originally set to 1.

Hope this helps out someone else who comes across this error.

During my search I also found that there is a Windows Installer 2.0 Bug which sometimes throws up this message. If there is a trace of an application previously having been installed, and you are trying to re-install it, you may get the above error. You can fix this by going to the registry to:


Browse through and find your product. Delete the key relating to your product and this should allow the application to install. I haven't had the opportunity to check this out. But just in case someone is reading this and might need this resolution give it a go.

0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Hi 5uf:

HKEY_CLASSES_ROOT\Installer\Products\ normally fixes the error that u described and most of the times it worked with me. Did'nt know abt the first key thanks for sharing the knowledge though.
Answered 08/25/2005 by: wiseapp
Second Degree Green Belt

Please log in to comment
to y0u5uf:

thanks for the tip it helped me solve a problem with alcohol 120% not installing correctly
Answered 01/14/2009 by: patoruso
Yellow Belt

Please log in to comment
I am having the same problem and am unable to install ESEt Smart Security. How can I access: HKLM\Software\Policies\Microsoft\Windows\Installer
Answered 08/20/2009 by: dfsahyoun
Yellow Belt

Please log in to comment
As the registry path suggests these settings are managed by AD group policy. Changing them is OK for testing purposes but any permanent changes required to this (or any other policy setting) should be considered and implemented by your group policy administrator.

A value of 1 means that Windows Installer is only enabled for managed deployments (read AD or SMS)

It's normally used to secure desktops and in conjunction with the AlwaysInstallElevated setting/s

Hope this helps,
Answered 08/20/2009 by: MSIPackager
Third Degree Black Belt

Please log in to comment
This is a personal computer and it is not allowing me to install the anti virus smart security from ESET software. Please walk me through... thanks
Answered 08/20/2009 by: dfsahyoun
Yellow Belt

Please log in to comment
Yes Thankyou


DisableMSI Type = 0 ( enable MSI )

This was originally set to 1 (disable MSI )

Also try this key ...

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects\{A541BD3D-1A70-4D7B-BC99-CF1ADFC0DE9F}Machine\Software\Policies\Microsoft\Windows\Safer

Change this value to 1 - to disable the Administrator only install a.k.a
anyone can do it.

If all fails .... The system Administrator has set policies
to prevent this installation,,,,, ensure you are logged on as Administrator
or any Administrative User privileges or Right click setup.exe and Run As Administrator
Answered 11/22/2011 by: levene
Yellow Belt

  • where do I go to the above to change the disable MS! type from 0 to 1?
    • This content is currently hidden from public view.
      Reason: Member has been banned from the site
      For more information, visit our FAQ's.
Please log in to comment

I have the same problem, could you please tell me how I can access this to change, I am a beginner :(

Answered 06/04/2013 by: ateam
White Belt

Please log in to comment
Answer this question or Comment on this question for clarity