Created a MSI script for TeamViewer and would like to deploy this via Dell Kace, but seeing that the Display name in the TeamViewer apps is the same. Have tried removing the following subkey and rescript this without any luck.

 

for 64 bit Windows 7 I found the key here…
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\TeamViewer\VersionX
for 32 bit Windows 7 the keys are here…
HKEY_LOCAL_MACHINE\SOFTWARE\TeamViewer\VersionX

 

Anyone who might be able to shed some light here?

 

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1

You can do a custom inventory rule for both sets of reg keys. 

Answered 05/16/2012 by: dugullett
Red Belt

  • Interesting? Do you have step by step on how I can do this?
Please log in to comment

Answers

This content is currently hidden from public view.
Reason: Removed by user request
For more information, visit our FAQ's.

0

You could create a zip file with TeamViewer.msi and  TeamViewer_Settings.reg then perform a managed install by calling TeamViewer.msi /qn /norestart.This should work for both 32bit and 64bit since the installer knows how to input that for both platforms. 

I have a k1000 and Teamviewer corporate license. Please let me know if this doesnt work. i will test it out myself.

Cheers!

Answered 05/22/2012 by: samuelcolt
Orange Belt

  • Samuel, did you deploy this via Kace system and will the UAC prompt to you to install it via End user PC.
    We do indeed have Corp license?
  • Hi Samuel,
    Did try to push this package via KACE Box using your command but only getting Display option on the end PC? What am I doing wrong here?
  • Actually i have disabled UAC on all our computers in the network. You could also elevate privilages for admin so UAC wont popup for admins. I think this could be done through registry or Group policy. Second option is to select "Execute before logon" from Managed action so UAC wont cause a problem. Please let me know if it works.
  • or select "Execute while user logged off"
  • Hi Samuel, I will give it ago in regards to the UAC and will keep you posted.
    Any ideas on how we can get the ID number change. Tried creating a team viewer_settings without any luck but doesn't seem to take effect.
    Possible you can provide step by step on how you did it?

    Appreciate your help on this.

    Hits
    • Samuel, managed to bypass this. Thanks a million!. Next issue is with the Team Viewer. anyway we can get the ID number to be changed as all the deployment come up with the same ID number?

      Cheers,

      Hits
  • This content is currently hidden from public view.
    Reason: Removed by user request
    For more information, visit our FAQ's.
  • Please make sure you export the TeamViewer_Settings.reg from Options>>Advanced>>Teamviewer option. Also it will be better if create a silent script to delete HKEY_LOCAL_MACHINE\Software\TeamViewer\ or HKEY_LOCAL_MACHINE\Software\Wow6432Node\TeamViewer\ on all the machines before you deploy the installer.
  • If this doesn't fix then you should send an email to the Teamviewer corporate team with the log files....
Please log in to comment
Answer this question or Comment on this question for clarity

Share