I must use an encrypted password.

I have changed the local security policy to allow blank passwords, I have saved the password as blank.

But I still coninue to get the error message during the sysprep part of the OS installation.

What have I missed?


My sysprep file contains:

[GuiUnattended]
AdminPassword=bla bla bla
EncryptedAdminPassword=Yes
OEMSkipRegional=1
TimeZone=85
OemSkipWelcome=1
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
One of the issues I found was that the "User may change password" bit must be set.

We have a password management utility that disables this and ended up costing me a weeks worth of troubleshooting before I figured it out.
Answered 08/09/2010 by: spottedcoin
Senior Yellow Belt

Please log in to comment
0
Is the "AdminPassword=" password actually encrypted in your systeprep.inf file, or is it in plain text?

INCORRECT: AdminPassword=MyPassword101
CORRECT: AdminPassword=eeaad3b435b51404ee0122f62a6b33b

http://support.microsoft.com/kb/302577
Answered 08/10/2010 by: Lucid
Purple Belt

Please log in to comment
0
ORIGINAL: spottedcoin

One of the issues I found was that the "User may change password" bit must be set.

We have a password management utility that disables this and ended up costing me a weeks worth of troubleshooting before I figured it out.


Thanks for your response, but on my reference machine I have checked and that is left at the default.

On a tangent - We have a self-service password reset system which has a client on every machine (including this master image), it’s called Verismic Password Reset and it is AWFUL - STEER CLEAR!!! And their support is even worse than the product.
Answered 08/10/2010 by: mcompton69
Orange Senior Belt

Please log in to comment
0
ORIGINAL: Lucid

Is the "AdminPassword=" password actually encrypted in your systeprep.inf file, or is it in plain text?

INCORRECT: AdminPassword=MyPassword101
CORRECT: AdminPassword=eeaad3b435b51404ee0122f62a6b33b

http://support.microsoft.com/kb/302577



Thats not quite accurate, you can use either plain text or enrypted, as long as the option is correctly set e.g EncryptedAdminPassword=Yes

In our case we have it set to yes, but still sysprep displays an error and fails to change the password.
Answered 08/10/2010 by: mcompton69
Orange Senior Belt

Please log in to comment
0
So you have EncryptedAdminPassword=Yes as well as having the actual password encrypted in the .INF file? If so, let me try backing up a step to get a better idea of what you're doing... What is the exact error message you are getting, and how are you syspreping your machine? I mean, are you using Ghost, MDT, SCCM, etc..., or just executing the command manually? Also, do you log off/restart after setting the password to blank, but before you sysprep it?

Lastly, does the machine run sysprep if you DON'T set the password to be encrypted?
Answered 08/12/2010 by: Lucid
Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity