We have Java Runtime Environment  1.7.0_45 installed on our pcs, we are seeing "Your Java version is out of date"

How to supress ?

 

2 Comments   [ + ] Show Comments

Comments

  • deployment.properties file, which is there in userprofile\sun\java
  • Be aware to SKJ, that the Windows Updates released today now cause IE to BLOCK all out of date versions of Java (with some exceptions). http://blogs.msdn.com/b/ie/archive/2014/08/06/internet-explorer-begins-blocking-out-of-date-activex-controls.aspx
Please log in to comment

Community Chosen Answer

1

Assuming it is Windows, I use the following setting;

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy]
"EnableJavaUpdate"=dword:00000000 

 


[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy]
"EnableJavaUpdate"=dword:00000000 - See more at: http://www.itninja.com/question/java-runtime-environment-6-update-14-disable-updates#sthash.QfEqtu8z.dpuf

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy]
"EnableJavaUpdate"=dword:00000000 - See more at: http://www.itninja.com/question/java-runtime-environment-6-update-14-disable-updates#sthash.QfEqtu8z.dpuf
Answered 03/23/2014 by: anwar.mahmood@outlook.com
White Belt

  • If running 32-bit version then: [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432\JavaSoft\Java Update\Policy]
    "EnableJavaUpdate"=dword:00000000
Please log in to comment

Answers

0

Start here to learn how the deployment.properties file works:

http://docs.oracle.com/javase/7/docs/technotes/guides/jweb/jcp/properties.html

You'll want to edit your deployment.properties file to include the line

 

deployment.expiration.check.enabled=false

I deploy the config and properties file using smart labels to target the machines and then a script to push the 2 files out to those machines. Works like a charm. 

 

Answered 02/17/2014 by: rockhead44
Tenth Degree Black Belt

  • Hey rockhead44,

    I have tried using deployment.properties, but it doesn't seem to be working correctly. It will apply the settings if I run the Control Panel applet (javaw.exe), but if I don't run that applet and go straight to a Java web application, it doesn't apply those settings and displays the warning. It's not realistic to expect all of our users to open the Control Panel applet every time they log in to a different computer (which happens daily). I have made a sloppy workaround by adding the registry settings on login, but I would prefer to not do that.

    Is there something I am doing wrong or is running the Control Panel applet the only way to apply the deployment.properties settings?
    • I push the files into C:\windows\Sun\Java\Deployment via file synchronization on my K1000 box
      The synchronization creates the directory if it does not exist. That works for me in my environment (thousands of machines) and the properties file suppresses the prompt. Admittedly, if users try to use java on a new machine prior to the file synchronization taking place they will see that message.
      • We've been trying to solve this since 7u65 came out. Are you running Win7 or XP? The deployment.properties file is located in: c:\users\<username>\AppData\LocalLow\Sun\Java\Deployment on our Windows 7 machines so it's not so easy to copy it to all those locations for all those users.
        I tried creating the folder and copying it to C:\windows\Sun\Java\Deployment anyway (the folder doesn't exist), but the message still appears. It doesn't look at that file, just the one in the User folder.
        Is there something I'm missing, to get Java to look in C:\windows\Sun\Java\Deployment instead or a change in the msi to install it there instead?
        Thanks for any suggestions
Please log in to comment
0
Try "setx deployment.expiration.check.enabled false /m"

This will create an environment variable to suppress the update checks which is being initiated by application exe itself.
Answered 05/27/2015 by: kp_pioneer
White Belt

Please log in to comment
Answer this question or Comment on this question for clarity