I am trying to automate the install of Sun Java 1.5.0_05. We currently have Sun Java 1.4.2_03 installed or MS Virtual machine. I have extracted the MSI files and modified the MST file but the first time that Java launches it comes up with a message "Check for Updates automatically?" I have set in the MST file javaupdate=0 and Autoupdatecheck=0. I do not want to offer this selection to the end user. Does anyone have any idea's on how to suppress this message from popping?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hi Xpdite,

Setting JAVAUPDATE to 0 should do the trick. Possibly you should leave AUTOUPDATECHECK set to 1. If that doesn't work there is something else going wrong.

Ilikebananas
Answered 11/01/2005 by: Ilikebananas
Purple Belt

Please log in to comment
0
Hi

I tried both of those settings but for some reason the first time the jave runs in IE it comes up with the autoupdate dialog box. I am confused.
Answered 11/01/2005 by: Xpdite
Orange Belt

Please log in to comment
0
Hi,

You can check what values your properties have when you install the package (from a verbous logfile). That will tell you if the installprocedure works as desired.

Ilikebananas
Answered 11/01/2005 by: Ilikebananas
Purple Belt

Please log in to comment
0
I have created the log file using verbose but I do not see if it is using the transform or not. I checked the java control panel after I install the application and the update box is not checked but the first time I run Internet Explorer java comes up and asks me if I want to configure the update properties.

I can send the log file if you would like to look at it.
Answered 11/01/2005 by: Xpdite
Orange Belt

Please log in to comment
0
Pls excuse me if im way off.... as i havent packaged this app... or taken a look at the msi...
But i noticed reg settings that i assume will be set based on the settings you guys were mentioning....

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy]
"EnableJavaUpdate"=dword:00000000
"EnableAutoUpdateCheck"=dword:00000000

The first setting enablejavaupdate removes the UI from java to stop users from altering the update settings.
The second key disables the actual update check from being enabled.

Maybe you could go the install again but before launching make a note to whats set in your reg... it might help troubleshoot ur problem further.
Answered 11/02/2005 by: rahvintzu
Orange Senior Belt

Please log in to comment
0
Thanks.

I will do that. Maybe it is not keeping the settings from the ttransform for some reason and as I am using Zenworks to deploy I can use it to make the registry changes after the install.
Answered 11/02/2005 by: Xpdite
Orange Belt

Please log in to comment
0
Hey everyone,

Just spent some time figuring this out. Sun added a new property in 1.5 Update 5 and higher. Here is what I'm using in my transform to avoid any type of annoying junk (updates, prompts, icons, etc)

C:\cscript WiLstXfm.vbs "J2SE Runtime Environment 5.0 Update 6.msi" "J2RE-1.5.0.06.mst"
Property Value [IEXPLORER] {0}->{1}
Property Value [JAVAUPDATE] {1}->{0}
Property Value [AUTOUPDATECHECK] {1}->{0}
Property Value [JU] {1}->{0}
Property Value [MOZILLA] {0}->{1}
Property Value [SYSTRAY] {1}->{0}
Property Value [WEBSTARTICON] {1}->{0}

A quick break down of what each does in this MST (based on observations):

IEXPLORER=1 (default=0)
- This selects the IE plugin

JAVAUPDATE=0 (default=1)
- This turns off part of the JavaUpdate

AUTOUPDATECHECK=0 (default=1)
- This turns off part

JU=0 (default=1)
- I'm pretty sure this is the property everyone hated. This is the new property in Update 5 and 6 that turns on that update prompt and leaves JavaUpdate on even if the JAVAUPDATE property is set to 0
- If were trying to figure out how to get rid of "PromptAutoUpdateCheck" under [HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy] to avoid the first run prompt, setting JU=0 takes care of this.
- This also handles setting "EnableJavaUpdate"=dword:00000000 under the same key

MOZILLA=1 (default=0)
- This selects the Netscape/Mozilla plugin

SYSTRAY=0 (default=1)
- This turns off the system tray icon when java applets are active

WEBSTARTICON=0 (default=1)
- This disables the creation of the web start link on the desktop (I think, always had this off)

Here is a dump of the HKLM registry for the main keys covered to show the results of using these properites.

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Plug-in\1.5.0_06]
"JavaHome"="C:\\Program Files\\Java\\jre1.5.0_06"
"UseJava2IExplorer"=dword:00000001
"HideSystemTrayIcon"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy]
"EnableJavaUpdate"=dword:00000000
"EnableAutoUpdateCheck"=dword:00000000
"NotifyDownload"=dword:00000001
"NotifyInstall"=dword:00000001
"Frequency"=dword:01170000
"UpdateSchedule"=dword:00000013
"LastUpdateBeginTime"=""
"LastUpdateFinishTime"=""
"InstallOptions"=""
"UpdateDescription"=""

Hope that helps. It's even more important to disable auto-update in Sun Java for businesses computers because Sun is now offering the Google Toolbar as an option during the Auto-Update installation (I believe selected by default but they do ask you). Here's a reference to the Google/Sun deal http://www.sun.com/2005-1004/feature/
Answered 12/03/2005 by: ewaite
Senior Yellow Belt

Please log in to comment
0
The list of registry entries you provided under [HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy] does not include anything called "PromptAutoUpdateCheck". Assuming that the MSI Property JU=1 was used, what Registry Entry needs to be installed to prevent the User Prompt? As a follow-on, what registry entries need to be set assuming the user did not select the "No" button on the prompt screen?
Answered 12/07/2005 by: Rick.Tuttle
Senior Yellow Belt

Please log in to comment
0
Oh sorry about that Rick, the prompt is caused by the key "PromptAutoUpdateCheck" being there (it is created by default on install). You have to delete that key if you didn't pass JU=1 on the install.

If you pass JU=1 or set the property using a MST, this key is not created and therefore nobody is prompted.

Hope that clears it up (but please ask if it doesn't...I need a coffee right now and might not be thinking straight [:D]).
Answered 12/07/2005 by: ewaite
Senior Yellow Belt

Please log in to comment
0
Wait...I've had coffee now. I mean JU=0 not JU=1 in my previous post to avoid having that key created. Told ya I needed a bit of a boost :)
Answered 12/07/2005 by: ewaite
Senior Yellow Belt

Please log in to comment
0
Okay - I've got it now.

JU=1 --> creates key "PromptAutoUpdateCheck" (with value=1)

To prevent all future update prompts delete key "PromptAutoUpdateCheck"

JU=0 --> prevents key "PromptAutoUpdateCheck" (with value=1) from being created.


So - in the MST, to stop all update activity, set the following Property/Value pairs:

JAVAUPDATE=0 (default=1)
AUTOUPDATECHECK=0 (default=1)
JU=0 (default=1)

So, where is any of this doumented by Sun?
Answered 12/08/2005 by: Rick.Tuttle
Senior Yellow Belt

Please log in to comment
0
Hey Rick,

Yes, you are correct. Those three properties are needed to disable any update activity. As for documentation from Sun...this isn't documented anywhere that I'm aware of.

-Evan
Answered 12/08/2005 by: ewaite
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity