When attempting to push the agent out to a newly built Windows Server 2008 R2 server with .Net 4.0 I get the following errors:
[MSGCODE: 066] .NET 1.1 not found. Enable install on 64 bit systems or preinstall prior to provisioning KBOX agent.
[MSGCODE: 002] KBOX Agent is not installed.

We are using the latest 5.1.36717 agent. Looking at some of the forum posts on this site a new 5.2 agent that didn't rely on .Net was expected early this year.

Is there an ETA on when an agent that doesn't require .Net might be available? I'd rather not have to install an old out of date .Net 1.1 just for the agent to run.

Matt Penner
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Hey Matt,

The 5.3 agent is out, but I don't believe they are going to post the links until next week. That said, support has been given the green light to offer it, so I'd open a quick chat session, and they should be able to get you set.

Answered 07/13/2011 by: cmccracken
Orange Senior Belt

Please log in to comment
I believe the latest agent is 5.1.38724, at least that was the version we got when we upgraded our K1000 to v5.2.38773. It appears to install fine without .NET 1.1, even on 64 bit Win 7.
Answered 07/15/2011 by: ncsutmf
Second Degree Green Belt

Please log in to comment
5.1.X Agents still have the .Net 1.1 Framework dependancy. As cmccracken said you can contact support for the 5.3 server and agent; it is the GA release, it's just not posted to the website at this very moment. Should be soon.
Answered 07/17/2011 by: cblake
Red Belt

Please log in to comment
I am a brand new KACE user and ran into this issue first thing. After reading this thread I was hopeful I could get the new client. Unfortunately the response to my request from support (today) was, "Currently the only agent available is 5.1.38724. and needs to have the .NET1.1 installed for provisioning. Our engineers are working hard to complete the 5.3 version that loses its dependencies on the .NET and move into the C+ code. Currently there is no proposed release date in writing for the new agent. If you choose not to deploy .NET1.1 to your 64bit versions the only action is not to provision them until the 5.3 release. Unfortunately there is not a workaround for this issue."

Since 95% of my clients are 64-bit Windows 7 without .NET 1.1, I think I'll hold off on deployment. I really wish I had known this before buying.
Answered 07/19/2011 by: chatcher
Yellow Belt

Please log in to comment
chatcher - As stated above, support should be able to provide you the pre-release 5.2 or 5.3 agent, but you will need to be aware that this is not release-quality code and should really only be used for testing. If you told support that your intention was to install on all of your workstations, that is probably why they're hesitant to release it to you.

I know your post was a week ago and 5.3 is still not out, but it is definitely very close according to all KACE folks here on the forum, and KACE support.
Answered 07/26/2011 by: TJSmithCIQ
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity