I am trying to install SNAGIT 11 on Windows XP and Windows 7. When launhed the shortcut "Snagit 11", Cliking Tools--> Program Preferences-->Program Options, here I need to check the box "Run Snagit when Windows Start".

Checking this option will created a shortcut under Start Menu --> Programs -->Startup (Snagit 11)... How ever I am not able to check this option in MST. I have tried to take capture but haven't found any thing. Is there any registry entry which I need to include. I have stucked at this place now. What should be done?

Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

3

This is for 10, but it might work: http://www.itninja.com/software/techsmith/snagit/10-369

It appears you can use TSC_START_AUTO=1 in the install command.

This link explains more: http://srikanthyellow.blogspot.com/2012/07/snagit-unattended-installation-i-am.html

Here is the enterprise install guide for 11: http://download.techsmith.com/snagit/docs/enterpriseinstaller/enu/10/Snagit-10-Enterprise-Installation-Guide.pdf

Answered 09/13/2012 by: jknox
Red Belt

  • I have used this property.. but no success. One more thing, I have advertised the Startup shortcut.. Will it effect the functionality. After advertising the Startup shortcut, I installed the package, restarted the System. When logged in , it will automatically go for Self heal (as shortcut is advertised).. and will register the product but won't launch the shortcut.. Suggest on ti. I can see still checkbox option "Run Snagit when Windows Starts" is disabled.
  • Did u try unadvertising the shortcut ? ALso try to figure out why the self heal is happening ?
  • There were 4 shortcuts out of which 2 were already advertised. The remaining were Startup shortcut and Quick Launch shortcut. I advertised both of them. But when I kept those 2 shortcuts as original the package was working fine..... So I have 2 advertised shortcuts in the package now...
Please log in to comment
3

Use any capturing tools like PictureTaker, InControl, PrismCapture, InstallRite, SysTracer etc.. and check whether the application is creating some other registry key/updating any file when you perform the below steps

Tools--> Program Preferences-->Program Options, here I need to check the box "Run Snagit when Windows Start".

As you said, just creating StartUp shortcut is not linked with this option in application window.. there should be some other reference in any file/registry.. Check it.

Answered 09/13/2012 by: jagadeish
Red Belt

Please log in to comment
3

You Have to set TSC_START_AUTO=1 Public Property this must work. I checked in this morning. 

Answered 09/14/2012 by: ontari.ontari
Black Belt

  • I had tried this thing but Settings were not coming even after that... But I Now I kept the shortcuts as it was there in Vendor MSI....
Please log in to comment
2

You can put the exe which the Snagit shortcut points to in run registry

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

OR you can yourself create a shortcut in Shortcut Table in the Startup folder

Answered 09/13/2012 by: SilentKiller
Orange Belt

  • This is a vendor msi . So I dont want to use Run key...
  • This content is currently hidden from public view.
    Reason: Removed by member request
    For more information, visit our FAQ's.
Please log in to comment
1

I have kept the shortcuts as it is (along with 2 unadvertised shortcuts)...

1. Disabled the Updates

2. Disabled the Improve Snagit Option

3. Disabled the registration support window which comes when you launched the shortcut 1st time.

 

Answered 09/19/2012 by: vmnit
Third Degree Blue Belt

  • Hi vmnit. How did you disable the registration support window? Followed the steps in the Enterprise Installation Guide and configured WasLicenseSent registry key but still no go. Did you set some additional registry settings or added some Properties?Thanks in advance.
  • Hey, Vmnit. Could you please let me know how to disable the registration support window which comes when you launched the shortcut 1st time. Please help me.
  • Hi,

    Sorry for being late. Here is the registry to suppress the registration part.

    [HKEY_LOCAL_MACHINE\Software\TechSmith\SnagIt\11]

    "NoAutoUpdateSupport"=dword:00000001
    "NoRegistrationDialogSupport"=dword:00000001
Please log in to comment
0

Ok, here you are the Auto Launch solution !

I had to cheat SnagIt and creating a CMD file with the command below in order to have the process on "Startup" and even without an icon the process will appear on the task bar and also minimized with the /i switch. Be careful if your deployment is x64 or x86 the command below applies only to x64 but you can modify it to adjust the path for x86. A log off /in is needed to see it happen. And I applied this fix for SnagIt 10 but should be the same thing for many other applications except for the /i that is just assigned to SnagIt.

reg add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run" /f /v "Snagit User Process" /t REG_SZ /d "C:\Program Files (x86)\TechSmith\Snagit 10\Snagit32.exe /i"

The problem I see here is that even if you modify your MSI to include : TSC_START_AUTO=1   I don't think that on large environments they would like to remove / reinstall the product if it was already deployed just to enable a couple of options.

What I have as a problem right now is to store the settings for SnagIt 10 and deploy them for all users of the current machine. As we already know that TechSmith don't know how to create a better logic for their products and they store the settings into the HKCU. The worst is that they admit their error but still don't have a corporate solution for that.

Regards.

Joel E.

Answered 11/25/2013 by: derspinne
Senior White Belt

Please log in to comment
Answer this question or Comment on this question for clarity