After looking @ The Package Knowledge Base and Snagit documentation i created a TRANSFORM with TSC_SOFTWARE_KEY. After installation i get a screen "Snagit Message Center" asking for a key. I then tried installing just vendor msi with passing a key on the cmd. "msiexec /i snagit.msi TSC_SOFTWARE_KEY=...................................."

And getting same prompt for a key again.
Also i can see that key must be in the HKEY_LOCAL_MACHINE\SOFTWARE\TechSmith\SnagIt\10]
"RegistrationKey"="INSERT-YOUR-KEY-HERE-XXXXX"

But its not getting there until i enter a key manually.

Am i using a wrong property? Has anyone created a TRANSFORM for snagit?

Thank you.

Just noticed the registry is populated only if i use /qb! switch.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
That would be my first guess. One thing that works pretty well is to do a verbose log, then look for the reg key in there. That will tell you the public property that is being set.
Answered 02/03/2012 by: Arminius
Second Degree Green Belt

Please log in to comment
0
Unless i use /qb the registry is not set.
I ended up just adding reg to a TRANSFORM. Just wanted to know, maybe there is a condition somewhere???
Answered 02/03/2012 by: ogeccut
Black Belt

Please log in to comment
2
Easy.

/QB means 'Basic UI' which means that there's a Custom Action which is running ONLy in InstallUISequence. You need to copy the CA to the InstallExecuteSequence. Do that in your MST.
Answered 02/03/2012 by: VBScab
Red Belt

Please log in to comment
0
Thank you.
Answered 02/06/2012 by: ogeccut
Black Belt

Please log in to comment
0
The command line to add key is TSC_SOFTWARE_KEY=xxxx-xxxx-xxxx-xxxx
Answered 02/07/2012 by: Timanator
Third Degree Blue Belt

Please log in to comment
0
You are correct. However this was not the question.

This command will only work if you use /qb switch. If you would like it to work without the switch you need to change "Set_TSC_LICENSEMODE" custom action from user to normal execute.

And i have this command line in the very first post.
Answered 02/07/2012 by: ogeccut
Black Belt

Please log in to comment
0
Not sure exactly why your silent isntall does not work, but our silent install is just:


msiexec /i"\\server\Snagit10.msi" /q REBOOT=ReallySuppress TSC_SOFTWARE_KEY=xxxx-xxxx-xxxx-xxx-xxxx USERNAME=NAME COMPANYNAME=COMPANY
Answered 02/07/2012 by: Timanator
Third Degree Blue Belt

Please log in to comment
Answer this question or Comment on this question for clarity