I've been searching all over for this, but no luck so far... Surely there must be a configuration for it! ("...And stop calling me Shirley!")

Some program setups which install networking drivers momentarily sever the existing network connection, so the program advertisement cannot be run directly from the DP, but must instead be downloaded first. Before SMS 2003, we had to script this to copy the files to a local directory and install from there; but now the 2003 Advanced Client offers us the "Download program from distribution point" option, which works great.

However, it gives the clients an unfriendly prompt stating that "This program must be downloaded before it can be run", with a needed checkbox that says, "Run program automatically when download completes."

So, is there a way to disable this prompt and have the client go ahead and run the program every time?
I don't care if we have to set it globally, as it apparently is not an option for the specific advertisement.

Thanks, all--
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Just use the "Supress Program Notifications" in the programs advanced tab. When the program is downloaded it will run without the user having to do anything...
Answered 03/15/2005 by: Ohmriff
Yellow Belt

Please log in to comment
0
Er, nope... Actually, the "Suppress Program Notifications" checkbox just keeps the little tooltip from popping out of the taskbar saying "A new program advertisement is available. Click here to open Run Advertised Programs..." or something like that when the client PC gets the new advert for the program.

A work-around for the question I asked can be found here at MyITForum question on the same topic. I've submitted feedback to Microsoft's SMS team to consider making a true silencing option in future revisions...
Answered 03/15/2005 by: ewall
Purple Belt

Please log in to comment
0
misunderstood you initial post, it reads as if you dont want any user interaction at all..
Answered 03/16/2005 by: Ohmriff
Yellow Belt

Please log in to comment
0
The link referenced for a workaround here is broken. I have this same question - does anyone know what the resolution was?
Answered 05/03/2007 by: clthoma
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity