Hi, I am trying to skip the EULA so users don't get asked to accept the first time they use the app, Powerpoint Viewer 2003

The first attempt I added the following registry setting to an MST

[HKEY_CURRENT_USER\Software\Microsoft\PowerPoint Viewer\11.0]
"EULAAccepted"=dword:00000001

This works fine if you launch the app from the start menu (Windows XPSP2). But doesn't work if you double-click a powerpoint file, you get prompted to accept the EULA. As most users will launch from this method I would like to supress the EULA.

I have tried using the ACCEPTEULA=1 property from a command line, this didn't work.
I have tried adding ACCEPTEULA=1 as a property in an MST, this didn't work.
I have tried adding AcceptEula=1 as a property in an MST, this didn't work.
I have added a ppt file association into an MST, this didn't work.

All ideas greatly appreciated.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
I would recommend taking a snapshot of what is generated when you accept the EULA in that manner and then add it to your package.
The InCtrl5 tool works great for that. Here is the link to download the tool: http://www.pcmag.com/article2/0,4149,25126,00.asp.

As a note, you need to be logged in as an administrator to use the tool. So first, take your first snapshot. Then doubleclick the ppt icon and generate the EULA & complete it. When finished, take the second snapshot and see what is generated. Then add it to your package. Good Luck!!
Answered 03/07/2006 by: DesktopEngineer
Yellow Belt

Please log in to comment
0
Thanks for the advice, I had already took a snapshot when launching this way and the only change was the aforementioned registry key.
We have just created an MST and used active setup to call a vbs file which populates the registry with the required key. Not very pretty but works! Cheers.
Answered 03/07/2006 by: sleach1
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity