So I've gone through my security settings and used domain admin credentials to have the K1000 join our domain.

It DID join successful.

I then checkmarked ENABLE SSO.

That portion was successful, as I have the option to DISABLE it.

 

It's not working.  :(

 

I've logged off and on, checked the logs for errors, tried the admin and the user portal, and it still wants me to sign in!  Close my browser, open, asks for sign in!

Any idea how this is 'supposed' to work?  Anyone gotten it to work?  Am I missing something by using a domain admin credential?

Answer Summary:
So, answered this myself, because I tend to overlook the tiny things before thinking it's a big issue. Mozilla firefox is not setup to allow SSO by default. it also helps to click the right SAVE SETTINGS button and reboot the machine. Sigh.
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

0

So, answered this myself, because I tend to overlook the tiny things before thinking it's a big issue.

Mozilla firefox is not setup to allow SSO by default.

 

it also helps to click the right SAVE SETTINGS button and reboot the machine.

 

Sigh.

Answered 09/13/2013 by: Wildwolfay
Red Belt

  • Also if you do a search for SSO in the Help area of the KBOX it will bring up a configuration article on how to configure the browsers.


    To use single sign on with Internet Explorer and Firefox browsers, users must configure their browser settings to use the appropriate authentication. The Chrome browser does not require any special configuration.
    Configuring Internet Explorer browser settings
    To configure Internet Explorer browser settings
    1
    In the Internet Explorer browser, click Tools > Internet Options > Security.
    2
    Select the appropriate security policy:
    •
    If the K1000 appliance is available on the Internet select Trusted Sites.
    •
    If the K1000 appliance is not available on the Internet, select local intranet.
    3
    Click custom level then scroll to the bottom of the list.
    4
    Select automatic logon with current username and password. If this option is not set, Internet Explorer cannot automatically log into the User Portal or Administrator Interface even if single sign is enabled on the K1000.
    To configure Firefox browser settings
    To configure Firefox browser settings
    1
    In the Firefox browser, type about:config in the address bar.
    2
    In the Search field type the following network.negotiate-auth.trusted-uris.
    3
    In the search results, double-click the name of the preference.
    4
    In the string value box, enter the URL of the K1000 appliance. For example, http://k1000.example.com, then click OK.
    • Took another look and I must've overlooked that little link at the bottom about configuring browsers.

      Ignored the little box :( bad me :(
Please log in to comment
Answer this question or Comment on this question for clarity