I have a MSI for a program - when you double click the MSI and click next it asks for 'production' or 'training' - production is selected by default...

When I install the MSI with msiexec /i program.msi (so its unattended automatic)

It installs the training option which is what I don't want

How can I change this? I'm guessing its a switch I need to type in with the /qb
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Hi aurz,
this smells like a feature issue. Please load the MSI-file into ORCA and have a look at the feature table and particular at the Level column.
Please report back, what you find there.
Regards, Nick
Answered 09/05/2006 by: nheim
Tenth Degree Black Belt

Please log in to comment
Chances are that the selection of Production or Training is governed by a (public) property.

Set up verbose logging first, then perform your interactive installation first. Locate and save a copy of the verbose log for this installation.

Next, either uninstall the application or (more preferably) set up a second clean test machine, and perform the silent installation. Locate and save a copy of the verbose log for this installation.

Assuming you set voicewarmup as the verbose option, you should see a full listing of the properties at the end of each log file. Compare the two property listings and see if you can spot a difference concerning Production / Training. Once you find the property, this can be supplied on the command line for the silent install. For example, if the property in question was named DATABASENAME, the command would be

msiexec /i <Name of your MSI> DATABASENAME=Production /qb-

Alternatively, if you have access to an MSI authoring tool (InstallShield / WISE &c), you could inspect the dialog that is used to prompt for Production or Training and find the underlying property that way.


Answered 09/05/2006 by: spartacus
Fifth Degree Brown Belt

Please log in to comment
Answer this question or Comment on this question for clarity