Guys,

I have an MSI that delivers an OCX file to view Tiff files in Internet Explorer (for GIS). When I install the application using the qb- switch (for our scripted SOE installation) it halts with a message box prompting me to register Internet Explorer as the default handler for these file types. I do want it to register, but I don't want to be prompted ... any ideas how to get around this?

Regards
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
You don't really specify what you mean by registering. If you're trying to register the OCX use the SelfReg table. That will register it silently. Also, try it with the /qn switch and see if that works for you. If there's something in the OCX which creates this dialog, then it's an app problem and not something you can correct with the MSI.
Answered 12/27/2007 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
Thanks for your reply.

The OCX is set to self register. The issue is that some of the filetypes it wants to "handle" (for example .tif) are already registered to other applications (Microsoft Picture and Fax Viewer). Instead of just overwriting the exisiting values, I'm being prompted by a message box asking if this is what I want to do.

I'll try the qn switch but I doubt that it will help ...

I need a fix for this, even if its a registry hack ... my last resort option will be to delete the offending registry keys, but I'd just rather silently overwrite

Regards
Answered 12/27/2007 by: kymdyer
Senior Yellow Belt

Please log in to comment
0
ORIGINAL: kymdyer

Thanks for your reply.

The OCX is set to self register. The issue is that some of the filetypes it wants to "handle" (for example .tif) are already registered to other applications (Microsoft Picture and Fax Viewer). Instead of just overwriting the exisiting values, I'm being prompted by a message box asking if this is what I want to do.

I'll try the qn switch but I doubt that it will help ...

I need a fix for this, even if its a registry hack ... my last resort option will be to delete the offending registry keys, but I'd just rather silently overwrite

Regards


Kym, if it's something that can be suppressed in the MSI then /qn should do it. That means absolutely no user inteface. /qb- means minimal user interface. If you use this in conjunction with logging /l*v "path to log file" then the log file should show you whether it was successful in registering it.

If it's a badly behaved OCX see what other options are available to register it. Regsvr32.exe is used to manually register files, /s is the silent switch for that OS command.
Answered 12/27/2007 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity