Greetings all,

I've seen the package database entry for creating an automated install for the oracle 8i package, but I'm getting a weird result I was hoping someone might be able to help me with.

I have tried creating the installer using the batch file etc as specified, but when I ran the batch file, nothing actually happened. I took the -silent option out to see what was happening and it appears that the source path isn't being generated correctly.

I have have the batch file, oraparam.ini etc. files in a directory like C:\install817, and the oraparam.ini has SOURCE=\\server\software\oracle817\stage\products.jar, then when the installer runs, it shows in the GUI the Source path as [current working directory]\[source directory] combined.


My batch file is in C:\install817
Source files are in \\server\software\oracle817
I make my working directory c:\install817 and run install.bat
When the GUI appears, the source path has c:\install817\\\server\software\oracle817\stage\products.jar
If I set my working directory to f:\software and run c:\install817\install I get
F:\software\\\server\software\oracle817\stage\products.jar as the source
It also doesn't seem to be setting the Destination Oracle Home name and path to what I have specified in the oraparam.ini or the .rsp file either!

Can anyone provide any ideas? I don’t really want to have to do *another* snapshot installation for Oracle if I can get the .rsp working instead! Did I mention how much I hate packaging Oracle clients?
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.



It sure doesn't make sense to me! How are you determining what the resulting source path is? Some potential things to watch for/try (that you may very well already know about)

- if you have a space in the path anywhere, you'll need double quotes around the entire path
- the original path was a relative path- make sure you have replaced the existing path and not added to the relative path. i.e. \\server\share\path\file and not ./\\server\share\path\file
- ensure you have updated all the other paths in the files to be full paths (JRE_Location, OUI_Location)
- UNC paths worked for me, but at least as a troubleshooting measure, try mapping a drive and then using the mapped drive for your paths.
- as long as you specify full paths everywhere, your current working directory should not matter- the fact that it does seem to be having an affect points to a relative path in somewhere that did not get updated. Look for "./" or "../" in your ini and rsp files which indicate the relative paths to the current and parent directory respectively.

You definitely don't want to repackage this one if you can avoid it! Hope this helps.
Answered 10/10/2003 by: bkelly
Red Belt

Please log in to comment
I've checked everything several times and it just wouldn't work...

I finally tried this and it does...almost.

Instead of creating a seperate Install directory, I just did all the modifications in the install directory where all the oracle client files are. I also left the SOURCE in the oraparam.ini file as SOURCE=..\stage\products.jar and it nearly all works. If I set the SOURCE to anything else it starts doing the "append the path" thing again.

Now I'm stuck at the next point. If I put the -silent option on the command line, the batch file runs, sits there for a while and then returns with nothing being installed. If I take the -silent away, then I can manually click "next" through the install and it has all the correct options and paths pre-entered. With the silent option, it doesn't seem to be creating any log files that I can find and there are no error messages anywhere either.
Answered 10/13/2003 by: thewspot
Senior Yellow Belt

Please log in to comment
I'm afraid I am not aware of any log files generated by this installation. InstallShield supports the -f2 switch to specify the location of the log file (and the name, setup.log by default) for your silent setup. The error code it provides is defined in the table found here. However, it is along shot that this would work. Odds are, the path problem you were experiencing still persists and is causing the silent failure. If you are using relative paths, play with setting your current directory. If you haven't tried it yet, give the START command a shot (type start /? at the command prompt). One of the things you can specify with START is the starting directory.

Good luck!
Answered 10/13/2003 by: bkelly
Red Belt

Please log in to comment
huh? I'm not sure why you're mentioning Installshield, this is all Oracle stuff using the Oracle Universal Installer (OUI).

With the Install directory in the same place as the actual source files, the path issue doesn't seem to be a problem, but I will keep playing with them a bit more to see if it makes a difference. If I manually step through the install, it seems to populate all the settings with what I have in the two answer files, but the install with -SILENT just fails with no apparent explanation...
Answered 10/14/2003 by: thewspot
Senior Yellow Belt

Please log in to comment
Found the problem....

Firstly, I installed only the oracle installer (OUI), thinking maybe the java runtime was causing problems or something. After that I ran my install.cmd again but it still kept failing. HOWEVER.....

After installing the OUI on its own, I noticed that there was a log directory created as well and a file called silentinstall.log was now being created. The log kept telling me that no value had been set for ORACLE_HOME.... I checked and checked and it was definately configured in the .RSP file....

After looking really closely, I then noticed the example values in the .rsp file all had quotes around them, so I added quotes to ALL the options I had set (just to be sure) and now it works fine.


I hadn't added quotes before as there are no spaces in my directory paths at all, but no quotes=no install...

So, maybe the "Check your Quotes" would be a good thing to add to the application database entry
Answered 10/15/2003 by: thewspot
Senior Yellow Belt

Please log in to comment
I'm installing Oracle 8i too, and i got the same problem with the install. The log mentions that there's no value for the variable ORACLE_HOME associated with the tolocation parameter, but in my response file, I have write a path like "c:\program files\oracle" for ORACLE_HOME.
If you have succed to install Oracle in silent mode, please can you explain me, how to realize that, thank you:)
Answered 02/06/2004 by: Ryang
Yellow Belt

Please log in to comment
I've had a problem with the Oracle 9i Client / Server install .rsp file and read somewhere that you have to have a mapped network drive (the OUI does not work with UNC '\\server\share' as a working directory)

And so as not to overwrite any users drive mappings I'm usingthe B: drive as a temporary drive letter and running a batch file from there..

All works ok for me, then I am running some script to update a few registry keys specific to our setup)

Steve. :o)
Answered 04/14/2004 by: SteveBA
Senior Yellow Belt

Please log in to comment
Steve.....and all.

I suggest you move the tnsnames.ora file out of the install and make it a separate install because the DBA's are going to change that file alot and you dont want to have to remove and reinstall it constantly.

Just a suggestion. :)
Answered 04/14/2004 by: MSIMaker
Second Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity