/bundles/itninjaweb/img/Breadcrumb_cap_w.png
Hi,

I am trying to do a package for MicroStrategy 8.0.1 and getting nowhere...

I found this very helpful entry in AppDeply from one of our contributors and I am able to record the setup.iss, BUT running the setup again (with --ResponseFile="C:\setup.iss" command line parameter) gives me the regular setup box and an UNsilent installation!?!!? If I use the -s (for silent installation) with -F1/-F2 parameters, then the installation LOOKS like its doing something (with the setup.exe showing in the Task List), but then quits without making any directories/files or links. The log shows that the process finished properly (but it hasn't).

I have tried re-running the installation and re-capturing the setup.iss in the C:\Windows directory and I have checked that the paths that I am giving are correct. All I can suggest is that the setup.iss was recorded incorrectly in some way (I have seen this with early response files recorded in Oracle Universal Installer).

I am installing upon Windows XP SP2 as an administrator.

Ideas?


Regards,


QuietLeni
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity

Answers

0
Hi Wildhair,

Yes... you are right, but I am having problems with the installation not removal!!!

BTW - thanks for the very helpful entry.

Regards,


QuietLeni
Answered 03/20/2006 by: QuietLeni
Yellow Belt

Please log in to comment
0
Hi Guys,

I'm trying to silently install Microstrategy 8.01 and having a similar problem to QuietLeni. I successfully created a setup.iss file using command:

setup.exe /r

BUT when I try to silently run the setup and setup.iss file using:
setup.exe /s setup.iss
the installation looks like it's doing something for about half a minute and then quits without making any changes.

The setup.log file however says it's installed successfully.

Here's what my setup.iss file looks like:

[InstallShield Silent]
Version=v7.00
File=Response File
[File Transfer]
OverwrittenReadOnly=NoToAll
[{B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-DlgOrder]
Dlg0={B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdWelcome-0
Count=11
Dlg1={B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdLicense2-0
Dlg2={B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdRegisterUserEx-0
Dlg3={B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdSetupTypeEx-0
Dlg4={B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdAskDestPath-0
Dlg5={B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdComponentTree-0
Dlg6={B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-MessageBox-0
Dlg7={B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdSelectFolder-0
Dlg8={B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdStartCopy-0
Dlg9={B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-AskYesNo-0
Dlg10={B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdFinishReboot-0
[{B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdWelcome-0]
Result=1
[{B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdLicense2-0]
Result=1
[{B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdRegisterUserEx-0]
szName=<user name here>
szCompany=<company name here>
szSerial=<serial number here>
Result=1
[{B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdSetupTypeEx-0]
Result=Complete
[{B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdAskDestPath-0]
szDir=C:\Program Files\MicroStrategy
Result=1
[{B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdComponentTree-0]
szDir=C:\Program Files\MicroStrategy
Bundles-type=string
Bundles-count=4
Bundles-0=Bundles\BundleAdo
Bundles-1=Bundles\BundleSte
Bundles-2=Bundles\BundleAxDist
Bundles-3=Bundles\BundleSequeLink
SystemFiles-type=string
SystemFiles-count=3
SystemFiles-0=SystemFiles\SystemSub
SystemFiles-1=SystemFiles\SystemMain
SystemFiles-2=SystemFiles\Xml
CommonFiles\Documentation-type=string
CommonFiles\Documentation-count=1
CommonFiles\Documentation-0=CommonFiles\Documentation\Documentation_Comp
CommonFiles-type=string
CommonFiles-count=9
CommonFiles-0=CommonFiles\CommonSub
CommonFiles-1=CommonFiles\CommonMain
CommonFiles-2=CommonFiles\CommonGUI
CommonFiles-3=CommonFiles\ChartActiveX
CommonFiles-4=CommonFiles\TriEdit
CommonFiles-5=CommonFiles\ReleaseNotes
CommonFiles-6=CommonFiles\OdbcDrivers
CommonFiles-7=CommonFiles\JRE142_06
CommonFiles-8=CommonFiles\Documentation
Desktop\DesktopArchitect-type=string
Desktop\DesktopArchitect-count=2
Desktop\DesktopArchitect-0=Desktop\DesktopArchitect\ProjectBuilder
Desktop\DesktopArchitect-1=Desktop\DesktopArchitect\DesktopArchitectGroup
Desktop-type=string
Desktop-count=5
Desktop-0=Desktop\DesktopFiles
Desktop-1=Desktop\DesktopAnalyst
Desktop-2=Desktop\DesktopDesigner
Desktop-3=Desktop\DesktopArchitect
Desktop-4=Desktop\DesktopAdmin
TutReporting-type=string
TutReporting-count=1
TutReporting-0=TutReporting\TutorialReportingFiles
TutReportingCommon-type=string
TutReportingCommon-count=1
TutReportingCommon-0=TutReportingCommon\TutReportingCommonFiles
CommonConfigurations-type=string
CommonConfigurations-count=4
CommonConfigurations-0=CommonConfigurations\WelcomeScreenShortcut
CommonConfigurations-1=CommonConfigurations\ConfigWizardShortcut
CommonConfigurations-2=CommonConfigurations\DesktopCharacterSet
CommonConfigurations-3=CommonConfigurations\CreateTutorialPSNs
Component-type=string
Component-count=8
Component-0=Bundles
Component-1=SystemFiles
Component-2=CommonFiles
Component-3=Desktop
Component-4=TutReporting
Component-5=TutReportingCommon
Component-6=CommonConfigurations
Component-7=SequeLink
Result=1
[{B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-MessageBox-0]
Result=1
[{B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdSelectFolder-0]
szFolder=MicroStrategy
Result=1
[{B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdStartCopy-0]
Result=1
[Application]
Name=MicroStrategy 8
Version=8.0.1
Company=MicroStrategy
Lang=0009
[{B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-AskYesNo-0]
Result=0
[{B339F3B3-E78C-45E8-B4D2-3C46C1C13663}-SdFinishReboot-0]
Result=1
BootOption=0

Any ideas why it might not be working?

Please Help [:(]
Answered 05/15/2006 by: Era
Yellow Belt

Please log in to comment