Hi All,

I am currently packaging a package that needs shorts with arguements in them. There are 3, and the shortcuts point to a 'exe' on a U: drive.
Using Wise Package Studio 5.6, and in the shortcuts section I create a shortcut fill in the command line and give it a name. Then I goto the details on the shortcut and fill the rest in.

Name : Uniform
Command Line : <path>\<exe>
Dest. Dirtectory : <path>
Arguments : <massive command line>



The rest are as default.

My questions are, is there a way I can fill in the command line with path that are longer then 8 characters. As it seems to chop of extra characters if it is longer the 8 characters.
I am trying to use variables, but it wont work....think I am going the wrong way about it.

I set up a variable in the 'Path Variables' and in the command line I put.

[TrainPath]uniface.exe

Can I do it like that, or do I need to set a Property up as well, or can I just use Properties to pass the path into the shortcut.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
How does the parameter string look like?
You can use property reference in the Arguments column if that helps.
You could use [#uniface.exe] instead if that file is installed with the package.

hmm Could you please explain it again? =)
Answered 08/31/2006 by: AngelD
Red Belt

Please log in to comment
0
Hi,

You might consider to create a shortcut file (.lnk) with your commandline and let the advertised shortcut point to the .lnk file.

Regards.
Answered 08/31/2006 by: dwight66
Senior Yellow Belt

Please log in to comment
0
A couple of thoughts here :

1) Does the path contains any spaces? If so, you could try enclosing it all in double quotes.

2) Using the property table to create a public property, e.g. PATH_TO_SERVER_EXE, might be a better approach. The value of this property should be set to the full path to the server based executable e.g "U:\<YourCurrentPath>\uniface.exe" . When setting up the shortcut command line, just use [PATH_TO_SERVER_EXE]

If in future, the drive mapping and/or the path was to ever change, your package need not be altered because the new path could now be specified on the command line as in the following two examples :

(i) A fresh installation of your package using a revised path and drive mapping :

msiexec /i <Name of your MSI> PATH_TO_SERVER_EXE="V:\<NewCurrentPath>\uniface.exe"

(ii) A reinstall of the same package to make existing client use a revised path and drive mapping :

msiexec /i <Name of your MSI> PATH_TO_SERVER_EXE="V:\<NewCurrentPath>\uniface.exe" REINSTALL=ALL REINSTALLMODE=vomus

Regards,

Spartacus
Answered 08/31/2006 by: spartacus
Black Belt

Please log in to comment
0
Ok I will explain again.

There are 3 shortcuts I want to add in to the package. The 'exe' files sit on a UNC path which is a U: drive.

Uniform test

U:\UniForm7\hometest\bin\uniface.exe /asn=asns\uniformrora9.asn /ini=U:\UniForm7\hometest\inifiles\ufrm1024.ini uni_form /dbs=TEST


UNiform Train

U:\UniForm7\hometrain\bin\uniface.exe /asn=asns\uniformrora9.asn /ini=U:\UniForm7\hometrain\inifiles\ufrm1024.ini uni_form /dbs=TRAIN


Gmstest

U:\UniForm7\homegmstest\bin\uniface.exe /asn=asns\uniformrora9.asn /ini=U:\UniForm7\homegmstest\inifiles\ufrm1024.ini uni_form /dbs=gmsTEST

These are the shortcuts that I want to add in, but the Uniform Train and GMS Test ones dont work as when it is installed the shortcuts are missing part of the paths.
The Train one misses the 'n' of the 'hometrain' and the GMS Test misses 'est' from 'homegmstest'.
Answered 08/31/2006 by: Thegunner
Second Degree Green Belt

Please log in to comment
0
Follow Mr. spartacus advice ;)

Also add properties for "/asn" & any other parameter part for the arguments column.
Future modification will be easier as spartacus stated.
I've done this way when refering to UNC/"mapped drive" for shortcuts och CA execution.
If you want the an advertised shortcut; just create a script that calls your shortcut target argument, in that way you can also verify that the U: drive is mapped.
Answered 08/31/2006 by: AngelD
Red Belt

Please log in to comment
0
ORIGINAL: spartacus

2) Using the property table to create a public property, e.g. PATH_TO_SERVER_EXE, might be a better approach. The value of this property should be set to the full path to the server based executable e.g "U:\<YourCurrentPath>\uniface.exe" . When setting up the shortcut command line, just use [PATH_TO_SERVER_EXE]




I went to the Setup Editor > Product > righted clicked on Properties and created a public property and set the value to the path of the executable. Then I put that public property I just created and put it in the Command Line of the shortcut with the [ ] and it didnt work. It said "The Parameter is incorrecet".

As I scroll down the property list, there is a Property in there that says "SHORTCUTPATH16" the value of that is the "[GMSTESTPATH_EXE]" the property i just created.
Answered 08/31/2006 by: Thegunner
Second Degree Green Belt

Please log in to comment
0
Do this in the Property table:
add the property with the desired value (ex. MYSHORTCUT=U:\UniForm7\hometest\bin\uniface.exe)
also add property for the argument (ex. MYSHORTCUTARG=/asn=asns\uniformrora9.asn /ini=U:\UniForm7\hometest\inifiles\ufrm1024.ini uni_form /dbs=TEST )
add this property to the Target column for the shortcut in the Shortcut table ("[MYSHORTCUT]") and the argument property in the Arguments column (ex. "[MYSHORTCUTARG]")
If you want to change these on the command line: msiexe.exe / .MSI TRANSFORMS=.MST MYSHORTCUT="what ever you want"
Answered 08/31/2006 by: AngelD
Red Belt

Please log in to comment
0
sorry, Shortcut table ("[MYSHORTCUT]")
should be Shortcut table ([MYSHORTCUT])
Answered 08/31/2006 by: AngelD
Red Belt

Please log in to comment
0
Cheers AngelD and spartacus, giving it a go now.
Answered 08/31/2006 by: Thegunner
Second Degree Green Belt

Please log in to comment
0
Ok Strange one, the icon on which I have done the above doesnt seem to appear. It should appear from START > PROGRAMS > UNIFORM > GMS > GMS - TEST (the shortcut)
Answered 08/31/2006 by: Thegunner
Second Degree Green Belt

Please log in to comment
0
Does the Icon column value point to the exact value in Icon table?
Did the shortcut work otherwise?

EDIT
Also check the IconIndex column
Answered 08/31/2006 by: AngelD
Red Belt

Please log in to comment
0
Here is the following information on the Shortcut Table and the Icon Table.

Shortcut Table

Shortcut Directory Name Component_ Target Arguments Icon_
GMS__TEST Uniform GMS - TEST Uniform ([GMSTESTPATH_EXE]) ([GMSTESTPATH_ARG]) IconF77F1FB2.exe

Icon Table

Name Data
IconF77F1FB2.exe {binary data}
Answered 08/31/2006 by: Thegunner
Second Degree Green Belt

Please log in to comment
0
It's only the icon and not the shortcut not showing right?

What did you're IconIndex column have?
Answered 08/31/2006 by: AngelD
Red Belt

Please log in to comment
0
The Shortcut is not showing at all.

I have tried it dwight66 way, of using the LNK files and got it working for the time being.

But I would like to get it working they way we have been trying at the moment.
Answered 08/31/2006 by: Thegunner
Second Degree Green Belt

Please log in to comment
0
Hello,

Try altering the shortcut table so that Target contains [GMSTESTPATH_EXE] and Arguments contains [GMSTESTPATH_ARG] respectively rather than ([GMSTESTPATH_EXE]) and ([GMSTESTPATH_ARG]) - i.e. remove the round parantheses - and let us know if this helps.

Regards,

Spartacus
Answered 08/31/2006 by: spartacus
Black Belt

Please log in to comment
0
Sorry if that was not clear enuf :)
Answered 08/31/2006 by: AngelD
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity