Hey all,

This is my first post, and i would like to say Fantastic website, i come here a lot!

My question is most likely very simple for you all to answer, and i'm not too sure if it has been asked or not...i've done some searches but i couldn't find any. Anywhoo, here is the question.

I have a vendor delivered MSI file. However with the 'great' wisdom of this vendor, they have somehow coded the application so that after the installation of the program, it puts ALL of the shortcuts into the logged in User Desktop and Program Folder. What i need is to redirect it so that it puts All of the shortcuts and the program folder into ALL USERS directory. I just can't seem to find how to do this...

Please let me know how to do this...Thank you all so much in advance!
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hello and welcome,

This is what I would do, I would make a batch file that runs the MSI via command line silent mode using 'START /wait' to call the msi. In the same batch file use xcopy to copy or you can even move the shortcut frm it's default location to the 'All Users' profile. This way is simple it keeps the MSI intact without modifying it.

Example:

start /wait c:\windows\system32\msiexec.exe /i <path to MSI> /qb ALLUSERS=1

move /y c:\documents and setting\Joe\Desktop\shortcut.lnk c:\documents and settings\all users\desktop


good luck.
Answered 11/07/2007 by: Coriolus
Orange Belt

Please log in to comment
0
i was thinking about it, and that would work, but here's the issue, i am deploying this application to thousands of workstations using a deployment tool....i am also using a script to utilize a local administrator to install this application. The issue is this, this particular local user doesn't really exist in all of the workstations...

so the best and easiest solution is to modify the MSI to make it drop the shortcuts onto the ALL USERS folder instead of Installed User Folder.
Answered 11/07/2007 by: NYCPackager
Senior Yellow Belt

Please log in to comment
0
Is the application installed per-machine (ALLUSERS=1)?
Check for any custom action (ex. Set Directory or Set Property) changing "ProfilesFolder" to [%USERPROFILE]

Run the installation with verbose logging as that may tell your more.
Answered 11/07/2007 by: AngelD
Red Belt

Please log in to comment
0
I checked for the ALLUSERS property on the property manager, however that particular property does not exist. I can add the property and set it to 1, but when i tried that, application doesn't install, and it just bombs out. i will try it once more and see how it goes. I do however see ApplicationUsers=AllUsers property...?

I've also checked for a custom action on the Property Manager, but i don't see any.
Answered 11/07/2007 by: NYCPackager
Senior Yellow Belt

Please log in to comment
0
ORIGINAL: NYCPackager

i was thinking about it, and that would work, but here's the issue, i am deploying this application to thousands of workstations using a deployment tool....i am also using a script to utilize a local administrator to install this application. The issue is this, this particular local user doesn't really exist in all of the workstations...

so the best and easiest solution is to modify the MSI to make it drop the shortcuts onto the ALL USERS folder instead of Installed User Folder.



That is exactly what I stated above, do a copy via batch file to the ALL USERS folder. ALL USers =1 won't always create shortcuts for all users.
Answered 11/07/2007 by: Coriolus
Orange Belt

Please log in to comment
0
Please specify which directory the shortcut(s) installs to.
Directory_ column in the Shortcut table.
Also provide the directory references for that directory from the Directory table.
Answered 11/08/2007 by: AngelD
Red Belt

Please log in to comment
0
Hey AngelD,

I've added the ALLUSERS=1 to the MSI and this time it seems to work...and i have been using this option since yesterday, and it is working perfectly so far...Thanks for the help on that one!!

now i have one more issue...not sure if i should create a new thread or not...but here it is.

This particular Application (the same one), requires a user account to install oddly enough. Let me make that clear...At my job, i use ZenWorks to do mass distribution, and i set the application object to use a System User to install applications. So i use a script to basically Run (Setup.exe, <flags>). The thing is if i use the System User account the application starts to install, but then it just stops. However, if i code the script to utilze a Domain / Local User account to install the application, it installs fine. How do i edit the MSI so that it doesn't have any ties to any user account?
Answered 11/08/2007 by: NYCPackager
Senior Yellow Belt

Please log in to comment
0
I guess the problem you're having while installing with the system account is due to lack of a "user" profile.
Install with verbose log should tell you where it bombs out.

I'm no expert in ZenWorks, hell... I've never used ZenWorks ;) so can't comment on that.
Answered 11/08/2007 by: AngelD
Red Belt

Please log in to comment
0
i was thinking that...the user that i'm installing it with isn't really a user account...and doesn't have a user profile...i'll try the activating the verbose log and see what happens...now to remember how to turn on the Verbose Log from the class...lol
Answered 11/08/2007 by: NYCPackager
Senior Yellow Belt

Please log in to comment
0
For verbose logging either add the (msiexec) /L*v switch and specify where the log-file should be placed or enable logging through policy for the log to be created under the user's %temp% folder.
HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer
Logging (REG_SZ) = voicewarmup
Answered 11/08/2007 by: AngelD
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity