We trying to use K1000 GO mobile app. We are unable to access from any device. My firewall team is telling me that i need to assign a public IP address and NAT it. Also that the K1000 server needs to reside in the DMZ. Is this correct? If not what can we do?

3 Comments   [ + ] Show Comments

Comments

  • Well the KBOX should have a static IP address anyways. If you are going to try to access the box from outside your newtork, yes you will need to make it available via NAT through your firewall and enable SSL or you can put the KBOX in the DMZ and also enable SSL.

    You also have to turn Mobile Go on from Settings > Control Panel > General Settings and also for each account as well under the USERS tab in Settings.
  • Nshah brought up the best question:

    Are you trying to access your kbox outside of your network?

    If not, then the locally assigned IP (and having peoples phones on the same network / sub-net as the k1000) would be more than enough.
    • We are trying to access the kbox from outside our network. We do not have the iPhones on the same network.
  • I use my VPN client on my iPad or iPhone and then access my KBOX through K1000 GO app. Works like a charm and we don't have to open up our KBOX to the outside world.
Please log in to comment

Community Chosen Answer

1

We assigned a public ip and opened the needed ports thru the firewall.

http://www.kace.com/support/resources/kb/solutiondetail?sol=SOL111775

Answered 09/24/2013 by: SMal.tmcc
Red Belt

Please log in to comment

Answers

0

How do we enable SSL on the Mobile Apps? Doesnt show up on mine,

hmm..

Answered 01/08/2014 by: hjansari
Fourth Degree Green Belt

  • In the most recent version of the app, you no longer need to toggle SSL on and off on the login screen -- the app automatically detects if your network has SSL enabled or not, and connects through the appropriate port. (note that if both port 80 and 443 are open, the app will always connect through 443.)

    If you have SSL enabled on your server, you'll be prompted to accept the certificate, but after that you're all set.
    • I got the prompt for the certification, and accepted that, but nothing happend instead got error message "Unable to contact IP address, but can ping using my PC."
      • Hmm, this makes me wonder if we missed a case in handling self-signed certs. Could you tell me which platform you're running K1000 GO on? iPhone or Android? And also, have you been running the app on HTTP successfully until now (and the server has recently enabled HTTPS), or is this the first time trying to connect to the K1000 appliance?
Please log in to comment
0

Using iPhone

Answered 01/08/2014 by: hjansari
Fourth Degree Green Belt

  • OK, I have tested the 1.1 iOS app against iOS 6 and 7, and changed the self-signed certificate multiple times, and I am not getting any failures related to the certificate. I guess I'll have to ask some more basic questions. Could it be that the "Mobile Device Access" setting in the K1000 General Settings is turned off? I tried that out, and noticed that the mobile app will report "Unable to contact IP address" if that switch is off, even though I can ping the machine on my workstation...
    • This worked like sharm..!
    • I did all of this but the am still get that error
Please log in to comment
0

When you enable "mobile device access" in System/General settings be sure to also enable access for the user account you are trying to login to K1000... it's in Organization_name/Settings/Users

 

Answered 01/15/2014 by: dlistar
Second Degree Blue Belt

Please log in to comment
Answer this question or Comment on this question for clarity

Share