We already have JRE 1.6.0_03 installed, but did not set the default browser to IE.

When I set the reg key HKLM\Software\JavaSoft\Java Plug-in\1.6.0_03\UseJava2IExplorer to 1, it shows the check mark in the Java Control Panel, but not in IE Advanced Options, and therefore applets fail. Manually setting IE in the control panel works fine, but I need a deployment solution.

I noticed when I set it manually via the control panel, a bunch of new keys get added to HKLM under Microsoft and Internet Explorer, but not when I just change the UseJava2IExplorer value.

What do I need to do to register JRE in IE by command line?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
bdog,
Try the deployment configuration file in addition to the MSI property settings... You'll have to search for all the available properties, but what i have here works nicely for me.. :)

You can add the files manually also - no command line needed - JRE will pick them up at next launch...

Create a file called "deployment.config" within it place these lines: (This files sets up where the actual config file will be located)
-------<START dont include this line>--------
deployment.system.config=file\:C\:/Windows/Sun/Java/deployment/deployment.properties
deployment.system.config.mandatory=false
-------<END dont include this line>--------

Add this to your MSI, into the [INSTALLDIR]\lib\ directory
- or - C:\Program Files\Java\jre1.6.0_03\lib in your case....
Create another textfile named "deployment.properties" within it place these lines:
-------<START dont include this line>--------
#deployment.properties
#Wed Feb 07 15:31:58 EST 2007
deployment.javaws.viewer.bounds=0,0,687,497
deployment.security.SSLv2Hello=false
deployment.system.tray.icon=true
deployment.version=1.6.0
deployment.browser.vm.iexplorer=true
deployment.browser.path=C\:\\Program Files\\Internet Explorer\\iexplore.exe
deployment.javaws.associations=REPLACE_ASK
deployment.security.TLSv1=true
deployment.javaws.shortcut=ALWAYS
deployment.browser.vm.mozilla=false
#Java Web Start jre's
#Wed Feb 07 15:31:58 EST 2007
deployment.javaws.jre.0.product=1.6.0_03
deployment.javaws.jre.0.registered=true
deployment.javaws.jre.0.osname=Windows
deployment.javaws.jre.0.platform=1.6
deployment.javaws.jre.0.path=C\:\\Program Files\\Java\\jre1.6.0_03\\bin\\javaw.exe
deployment.javaws.jre.0.location=http\://java.sun.com/products/autodl/j2se
deployment.javaws.jre.0.enabled=true
deployment.javaws.jre.0.osarch=x86
#Java Plugin jre's
#Wed Feb 07 15:31:58 EST 2007
deployment.javapi.jre.1.6.0_03.args=
deployment.javapi.jre.1.6.0_03.osname=Windows
deployment.javapi.jre.1.6.0_03.path=C\:\\Program Files\\Java\\jre1.6.0_03
deployment.javapi.jre.1.6.0_03.osarch=x86
-------<END dont include this line>--------
Add this to your MSI, into the "%windir%\Sun\Java\Deployment\" directory
-- C:\windows\sun\java\deployment
Just like it is setup in the deployment.properties file....

Enjoy
-Grant
Answered 12/07/2007 by: gmorgan618
Blue Belt

Please log in to comment
0
Thanks, I followed your instructions and nothing happened. I created and dropped the deployment.config and deployment.properties files into %windir%\Sun\Java\Deployment as you specified, then went to one of our intranet java sites and got a red 'x' placeholder. IE isn't checked in Java or IE either. Am I supposed to refresh the settings somehow? Do you think there is a problem with your file referencing version 1.5x and I'm using 1.6x? I wasn't sure if it would update itself and it didn't.
Answered 12/07/2007 by: bdog
Senior Yellow Belt

Please log in to comment
0
.The setup i posted needs the files to be placed to to seperate locations

deployment.config -> %ProgramFiles%\Java\jre1.6.0_03\lib
-This file points to the location of the properties file

deployment.properties -> %windir%/Sun/Java/deployment/deployment.properties
-This file contains the settings

... Did this fix the issue?
Answered 12/10/2007 by: gmorgan618
Blue Belt

Please log in to comment
0
Ok, this is getting odd. I made the correction and nothing happened. IE was still not checked as the default browser. We also use a proxy, so I thought I would add the info and see what happens. I added the following line to deployment.properties:

deployment.proxy.auto.config.url=http\://our.proxy.server

When I re-opened the Java Control Panel, the proxy info was there. So I know the file is working as you said it would; however, I can't seem to get IE checked as the default browser.

I read the info on the Sun site and added the line 'deployment.browser.vm.iexplorer.locked' and it greyed out Internet Explorer in the Java Control Panel. Everything appears to work just fine, except for checking the default browser.

I was wondering, are you able to toggle between IE being checked and unchecked using deployment.properties? Also, if you manually uncheck IE and you have deployment.browser.vm.iexplorer=true, does it re-check itself in the Java Control Panel when you reopen it?
Answered 12/10/2007 by: bdog
Senior Yellow Belt

Please log in to comment
0
Hi John,
did you read this: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6439899
and this: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6439996
and this: http://forums.java.net/jive/thread.jspa?messageID=159908
Regards, Nick
Answered 12/10/2007 by: nheim
Tenth Degree Black Belt

Please log in to comment
0
I have now! Thanks for the links, please correct me if I'm not comprehending them as you intended.

The first two deal with locking properties, which I don't need. I only locked the browser property as a test and it worked fine. I'm not sure what to make of the third link, it doesn't seem to appy to me, unless you think I'm placing the files in the wrong folder.

I know it's functioning since I can set other properties just fine. I just can't seem to force the default browser to check itself either at install, or if a user unchecks it.

Just to be sure, I put the file in my user profile where the default deployment.properties lives. Nothing happened. I did find the registry keys that change, but I'm not sure if that is advisable. I would rather do it the right way.

Here are the keys that change when I manually set IE, just for your information:

[font="courier new"][HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Plug-in\1.6.0_03]
"UseJava2IExplorer"=dword:00000001
[font="courier new"]
[font="courier new"][HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{08B0E5C0-4FCB-11CF-AAA5-00401C608500}]
@="Java (Sun)"
"ComponentID"="JAVAVM"
"IsInstalled"=dword:1
"KeyFileName"="C:\\Program Files\\Java\\jre1.6.0_03\\bin\\regutils.dll"
"Version"="5,0,5000,0"
"Locale"="EN"
[font="courier new"]
[font="courier new"][HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\AdvancedOptions\JAVA_SUN\SELECT]
"RegPath"="Software\\JavaSoft\\Java Plug-in\\1.6.0_03"
"Text"="Use JRE 1.6.0_03 for <applet> (requires restart)"
"Type"="checkbox"
"ValueName"="UseJava2IExplorer"
"HKeyRoot"=dword:80000002
"CheckedValue"=dword:1
"DefaultValue"=dword:1
"UncheckedValue"=dword:0
[font="courier new"]
[font="courier new"][HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\AdvancedOptions\JAVA_SUN]
"Text"="Java (Sun)"
"Type"="group"
"Bitmap"="C:\\Program Files\\Java\\jre1.6.0_03\\bin\\regutils.dll,1000"
[font="courier new"]
[font="courier new"][HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Extensions\{08B0E5C0-4FCB-11CF-AAA5-00401C608501}]
"MenuText"="Sun Java Console"
"CLSID"="{1FBA04EE-3024-11d2-8F1F-0000F87ABD16}"
"ClsidExtension"="{CAFEEFAC-0016-0000-0003-ABCDEFFEDCBC}"
Answered 12/10/2007 by: bdog
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity