Hi all,

I have a problem setting custom permissions on C:\WINDOWS folder using InstallShield on Windows 7 X64. Under the general settings in InstallShield I set "Custom Installshield handling". Then under files and folders I choose WindowsFolder. Rightclick, properties - permissions. Add "new". Choose "Interactive" and set whatever permissions. Compile and install -> nothing happens. I have tried using different users such as "authenticated users" and such, with same results. I have also tried to put the component where the permissions are set to 64-bit component and also put the template summary into x64.
I have no problems setting ACL on different folders as far as I know. Just the WINDOWS-directory. 

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1

Why do you want to give permission to C:\Windows folder. It is not recommended..

C:\Windows folder will be having OS and installed applications critical files.. Giving permission to this folder will cause many security problems in production environment..

You have to author your package to work in locked down environment..

Answered 11/23/2012 by: jagadeish
Red Belt

  • It´s because the application writes a configuration file to this directory which will change over time depending on what setting the user wants. I know it´s crazy from a security perspective but the application works like this and the vendor of it will not change anything.
    I guess the problem changing ACL on C:\WINDOWS in Windows 7 using a MSI is because the administrator account which I use don´t even have permission to change it if I try to do it manually. "Trusted installer" had righs to do it, by design I guess.
  • I would suggest if you know the configuration file name.. then add a dummy file with same name into your package and grant write access to the file.
Please log in to comment

Answers

0

 

I would suggest if you know the configuration file name.. then add a dummy file with same name into your package and grant write access to the file.

Answered 12/06/2012 by: mahendraKumar
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity