Hi Guys,

I have created a MSI in Wise... its working fine with a same user who installed it.. but when I log off that user and connect a standard user...and try to launch the application it was doing a selfhealing.. after selfhealing finished the application start working fine and then after i close the application and relaunch it work fine without selfhealing... now my question here... wht should i do to avoid the first time selfhealing...

I will appreciate your immediate response.

Thanks
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
From what you have said it sounds like your application is working just as it should. When a new user launches the application and there are say registry entries required in HKCU self healing is required to populate those the first time the application is launched. So to answer your question; to avoid first time self healing you need to insure that the program you have created does not need to write any registry entries to HKCU or files to the users profile.
Answered 07/14/2008 by: joedown
Second Degree Brown Belt

Please log in to comment
0
Thank you so much for the respone, but how do i do that in order to ensure that it won't write any registries to a HKCU, can you please take me through the steps since I am kind of new to all this,

Thanks
Answered 07/14/2008 by: dev5000
Orange Belt

Please log in to comment
0
Bizarre advice...if an app needs registry entries in HKCU (shorthand for the HKEY_CURRENT_USER registry hive), it needs them. Removing them from an MSI may mean that the app doesn't start up correctly or, in one case I had recently, at all. Yes, the app *should* create them on-the-fly but it seems vendors like to employ wet-behind-the-ears developers who wouldn't know defensive programming if someone shoved a book about it down their gullets.

Anway, if that's what you want, just delete all registry keys that the MSI creates in that hive. Good luck.
Answered 07/15/2008 by: VBScab
Red Belt

Please log in to comment
0
yeah dev5000 i think you are missing the point here. This is by design and for very good reason. You do not want to disable this functionality.

If you really want to stop it as Ian said remove the keys and or use this

DISABLEADVTSHORTCUTS Property
Setting the DISABLEADVTSHORTCUTS property disables the generation of shortcuts supporting installation-on-demand and advertisement. Setting this property specifies that these shortcuts should instead be replaced by regular shortcuts.
Default Value
By default, installation-on-demand shortcut generation is enabled.
Remarks
The shortcuts that support advertisement have the name of a feature, rather than a formatted file path of the form [#filekey], entered in the Target column of the Shortcut table. If this property is set and the feature is installed, the installer generates a regular shortcut to the feature.
This property is commonly used by administrators for users who roam between environments that do and do not support advertising. This property can be set by a transform, in the administrative stream, or in the Property table. If it is set using the command line or by a call to MsiSetProperty, then it must be reset again during each subsequent installation.
Answered 07/15/2008 by: jmcfadyen
Fifth Degree Black Belt

Please log in to comment
0
Thank you Guys for being so supportive, I really appreicate the response I think I'll leave it like that as you suggested :)

Thanks
Answered 07/15/2008 by: dev5000
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity