Hi all,
Thanks for your support provided so far. In our application we have self repair option done through the Control Panel->Add/Remove Programs->Click here for Support Information(link) and we want self repair to be done in a restricted user.
The self repair starts but after some time we get error as

"Error 1730. You must be an Administrator to remove this application. To remove this application, you can log on as an Administrator, or contact your technical support group for assistance."


The self repair is working in Administrator mode but the above specified error is displayed in non-admin mode. We have set the AlwaysInstallElevated key to 1. Still its not working.


When we checked log file it seems Install initialize custom action is creating problem.The Log file generated is as below:

MSI (s) (70:9C) [02:35:47:288]: Doing action: InstallInitialize
Action ended 2:35:47: SetSREServiceURL. Return value 1.
MSI (s) (70:9C) [02:35:47:288]: Machine policy value 'AlwaysInstallElevated' is 1
MSI (s) (70:9C) [02:35:47:288]: User policy value 'AlwaysInstallElevated' is 0
MSI (s) (70:9C) [02:35:47:288]: Note: 1: 1730
Action start 2:35:47: InstallInitialize.
MSI (s) (70:9C) [02:35:50:125]: Product: Globalfs Server 1.73.2205.0 -- Error 1730. You must be an Administrator to remove this application. To remove this application, you can log on as an Administrator, or contact your technical support group for assistance.

MSI (c) (5C:AC) [02:35:47:328]: Font created. Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

Error 1730. You must be an Administrator to remove this application. To remove this application, you can log on as an Administrator, or contact your technical support group for assistance.
Action ended 2:35:50: InstallInitialize. Return value 3.
Action ended 2:35:50: INSTALL. Return value 3.

Kindly help us to proceed.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Did you look at the LaunchCondition table?
Answered 03/18/2008 by: AngelD
Red Belt

Please log in to comment
0
The self repair is working in Administrator mode but the above specified error is displayed in non-admin mode. We have set the AlwaysInstallElevated key to 1. Still its not working.


I believe this registry key is both HKLM and HKCU and I believe you need both for it to function properly.

If you're using policies instead it would be both a Computer and a User policy.
Answered 03/18/2008 by: MicrosoftBob
Blue Belt

Please log in to comment
0
Hi all,
Actually there was launch condition to check the version of IIS 5.0 . When I tried to do a self repair in restricted user it displayed the error as access denied for the user to access the IIS version. So I bypassed the launch condition by checking
If NOT Installed then
Launch Condition
End
So the launch condition will not be checked for the self repair. After doing this I tried the self repair in restricted user and it displays the error message as shown in the previous post.
Kindly guide me to proceed.

Answered 03/18/2008 by: bhuvan
Senior Yellow Belt

Please log in to comment
0
(sigh).....As ever, Bhuvan, run the repair with ProcMon or your choice of process/file/registry monitor. It will tell you what registry and/or file access is taking place. This advice applies to repairs, healing, installs or uninstalls, whatever it is you're doing.
Answered 03/19/2008 by: VBScab
Red Belt

Please log in to comment
0
Bhuvan, did you check to see that the AlwaysInstallElevated is set to 1 in both the Computer and User (HKLM & HKCU) policies?

You should not get this error if both are set.
Answered 03/19/2008 by: MicrosoftBob
Blue Belt

Please log in to comment
0
I checked the HKLM and HKCU , the AlwaysInstallElevated is set to 1 in HKLM only and its not setting for HKCU.
Answered 03/20/2008 by: bhuvan
Senior Yellow Belt

Please log in to comment
0
ORIGINAL: MicrosoftBob

Bhuvan, did you check to see that the AlwaysInstallElevated is set to 1 in both the Computer and User (HKLM & HKCU) policies?

You should not get this error if both are set.
I expect Bhuvan just forgot to say 'thanks', Bob.
Answered 03/25/2008 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity