I'm using the following to setup an odbc connection. The script works and adds the entry to the registry but if you go look in Windows under odbc connections-systemDSN it is not listed. Not sure what I am missing. Thanks.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI\Munis Crystal Reports]
"Driver"="C:\\Windows\\system32\\sqlncli.dll"
"Description"="Munis Live Data"
"Server"="Ourservername"
"Database"="Ourdatabasename"
"LastUser"="sa"
"Trusted_Connection"="Yes

"

Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1

Got it figured out. Needed to add a key under data source as well.

Thanks for the help.

Answered 10/11/2012 by: ckubaska
Fourth Degree Brown Belt

  • let me guess
    [HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI\ODBC Data Sources]
    "Ourdatabasename"=
Please log in to comment

Answers

0

Is it 64 bit?

Answered 10/11/2012 by: dugullett
Red Belt

  • Would like to have it work on x86 and x64 eventually but currently attempting x86.
Please log in to comment
0
Did you install and register sqlncl.dll? http://social.technet.microsoft.com/Forums/en-US/excel/thread/189ae710-8b1c-4285-99d1-e6f5e6a7740b/
Answered 10/11/2012 by: SMal.tmcc
Red Belt

  • Yes, installed and registered. I can setup the odbc connection manually in system dsn and it works. I've exported the registry key and attempting to add it on a test box. It adds to the registry but doesn't show under system dsn if you go into it in windows.
Please log in to comment
0

Hoping this shows a bit better what is happening. I've added an odbc in data sourse admin and it shows in this location in the registry but if I add it in the same area in the registry and do not use data sourse administrator it fails to show in the list.

Answered 10/11/2012 by: ckubaska
Fourth Degree Brown Belt

  • see if this link helps any
    http://www.sqlservercentral.com/Forums/Topic106237-5-1.aspx#bm110030
  • Are you launching the x86 version of ODBC?
    C:\windows\syswow\odbcad32.exe
Please log in to comment
Answer this question or Comment on this question for clarity