I'm deploying MSI and MST files with Wise Package Studio and they work as expected when started manually with msiexec /passive /i application.msi or msiexec /passive /i application.msi TRANSFORMS=transform.mst.

But when they are deployed with the same command to the clients with SCCM 2007 they behave differently.

Some of them runs silently.
Some of them doesn't show up in ARP.
Some of them run silently and doesn't show up in ARP.
Some of them work ase expected.

Are there some settings I need to modify in the MSI/MST or on the Packages in SCCM?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Have you checked the execmgr.log in the directory CCM\Logs? I have an SCCM2007 implementation here and I haven't experienced any problems with the successful execution of advertisements.

Look in All Areas or Software Distribution area in your RAP applet.
Answered 02/15/2008 by: oofemioo
Blue Belt

Please log in to comment
0
The problem with silent mode instead of passive is solved, the SCCM guy found out the meaning of allowing user interaction.

Embarrising... The problem with ARP is solved, I've forgot to set ALLUSERS=1 in som packages...

Now the weekend starts here in Sweden, I think I need it.

oofemio, thanks for the reply.
Answered 02/15/2008 by: Bobo
Orange Belt

Please log in to comment
0
I'm also experiencing the same type of issues as Bobo.

We have successfully managed to deploy 12 or so applications from SCCM, however two of the applications seem to install but with no ARP or icons (desktop or start menu). Both these applications install successfully manually or from a command prompt using the /qb /norestart and /i switches. When they are deployed through SCCM we use the same command line as the other apps and the same command line used when started manually from the client.
Answered 05/28/2008 by: waster656
Yellow Belt

Please log in to comment
0
Sounds like it's installed per-user.
If so install as per-machine; add the ALLUSERS property and give it a value of 1.
Answered 05/28/2008 by: AngelD
Red Belt

Please log in to comment
0
I have already tried adding the ALLUSERS=1 to the end of the command line
Answered 05/28/2008 by: waster656
Yellow Belt

Please log in to comment
0
Have you looked at the MSI log to see what options are being passed at install?
Answered 05/28/2008 by: kkaminsk
Ninth Degree Black Belt

Please log in to comment
0
No, where is it the log file stored by default?

Thanks for all your help so far.
Answered 05/28/2008 by: waster656
Yellow Belt

Please log in to comment
0
Thanks for all your help - I managed to resolve today. It seemed it was the ALLUSERS that needed to be added. SCCM seemed to have got itself stuck in some kind of loop trying to deploy a previous version. Our SCCM guy appeared and fixed all OK.
Answered 05/29/2008 by: waster656
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity

Share