We put up RSA's in each of our locations. All on the same hardware. For some reason, imaging from the RSA is slow. It maxes out at like 40mbps, no matter how many we have imaging - so 5 going at once made it insanely slow (2hrs+ using WIM). Any ideas as to why this is like this? We can image off-site to our main K2000 box a LOT faster than this, so there is something wrong with the RSA setup - but I can't figure out what it is. 

Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers


  • How do I change the NIC to E1000 instead of Flexible? It just says it's Flexible, and doesn't give me an option to change it. I'm on VMWare Server right now.
    • It's hard for me to say since I do not user server, but you should have "ethernet0.virtualDev = "e1000" in your .vmx file.

      Reading from this post it sounds like you need to add a new E1000 nic, and delete the flexible.
  • Or is this a hardware related? Do I actually need to switch out the NIC with a newer one, or is it a setting in VMWare Server?
  • This content is currently hidden from public view.
    Reason: Removed by user request
    For more information, visit our FAQ's.
  • This content is currently hidden from public view.
    Reason: Removed by user request
    For more information, visit our FAQ's.
  • Ok - So I input ethernet0.virtualDev = "e1000" in my VMX advanced settings in VMWare Server. I then have an option for the e1000 NIC, but it says it's not supported under VMWare Server 2.0.2.......How the hell are people getting this to work on VMWare Server? This RSA is the biggest pain that I've had to deal with in regards to the whole KBOX experience.
    • Since I don't use VMWare server it's hard for me to say. If I get some time later I'll run it.
  • Ok - I can set it for FreeBSD (64bit), and set the NIC to e1000, but once it boots, no machine can ping it at all. Any ideas?
  • I'm pretty sure you want it at FreeBSD (32-bit); from CSerrins' comment, I don't think they made the RSA 64-bit. Past that, I have to agree, changing over to the E1000 knocks it off the network. It looks like it will work if you force it to 1000 MB in the Konfig console. The default is auto-negotiate.
  • This content is currently hidden from public view.
    Reason: Removed by user request
    For more information, visit our FAQ's.
  • This content is currently hidden from public view.
    Reason: Removed by user request
    For more information, visit our FAQ's.
  • You can upgrade the VMWare Tools if you shut down the RSA, Edit the Virtual Machine settings, add a CDROM in the Add Hardware area, use a Host CDROM, and start the VM again. Then go to Inventory -> Virtual Machine -> Guest -> Install/Upgrade VMWare Tools. Log into the RSA, and go to Settings and Maintenance -> Aopliance Maintainence tab -> Edit -> Update VMWare Tools.
Please log in to comment
3

If using VMware Server, it only lets you create an e1000 adapter if you're using a 64-bit OS. You'll need to do the following:

  1. Shut down your RSA
  2. Change the virtual machine OS to FreeBSD 64-bit
  3. Delete the current network adapter (Flexible NIC)
  4. Create a new network adapter (you can verify that it is an E1000 by going into the NIC details)
  5. Change the OS to back to it's original setting
  6. Turn on the RSA
  7. Log in with username: konfig and password: konfig
  8. Change the IP address to something else temporarily and change the NIC speed to 1000 Mbps Full-Duplex. Save your changes, and it will reboot the RSA. NOTE: You must change the IP address so that it properly assigns the address to the new adapter.
  9. Log in with username: konfig and password: konfig
  10. Change the IP address back to your desired IP, save, and the RSA will reboot.
Answered 07/20/2012 by: warmep
Second Degree Green Belt

Please log in to comment
2

What type of NIC is listed for the VM?

You should upgrade to Hardware Version 7, make sure OS is set to FreeBSD 32-bit and install the tools.

If NIC is set to flexible, I believe that is 100Mb, you need to change to e1000.

Corey

Lead L3 Enterprise Solutions Engineer, K2000

If my response was helpful, please rate it!

Answered 07/16/2012 by: cserrins
Red Belt

  • I'm using VirtualBox - and just loaded the OVF into it, set IP's, and that's it. I don't see any options for those. Is there a tutorial on how to set all of those options up?
  • FreeBSD is the OS. I don't see an option for Flexible NIC though.
  • Here is a screenshot of the network settings on the VM: https://dl.dropbox.com/u/119117/kace/rsa1.PNG
  • That PCNet PCI II NIC is a 100Mb adapter, are there other settings there?
    We don't usually recommend virtual box for an RSA, VMWare Server or ESXi are both free and more stable.

    Corey
    Lead L3 Enterprise Solutions Engineer, K2000
    If my response was helpful, please rate it!
  • Is there a tutorial on doing this? We're in the middle of deploying 1,200 machines right now and this really put a kink in our operation. We're having to image over our WAN which is not ideal.
  • We are having the same issues. The speed of the RSA compared to the K2000 is terrible, the same image running on the K2000 takes 20 minutes and the RSA takes 20 hours!
  • After talking with KACE support on the phone, VMWare Server doesn't let you choose e1000 instead of Flexible. The only way of getting e1000 is to change the OS to FreeBSD 64bit, and then the network isn't responsive after you do that since the RSA is 32bit. So according to support, the only way to get it is through ESXi, so the KACE team should NOT recommend VMWare Server if that is the case.
  • Please see comments before changing settings as CSerrins has suggested. Doing this will take down your RSA and make it unreachable on the network until you go into the Konfig console and force it to use 1000 MB rather than Auto-negotiating the NIC speed.
Please log in to comment
Answer this question or Comment on this question for clarity