I am having a hard time repackaging WinZip 9.0. I have tried to use both Installshield AdminStudio 5.5 and Wise Package Studio 5 and I get the same error with both. I start a capture and run Winzip's setup.exe. After compiling the MSI the error in my package is as follows: After the new package of WinZip is installed, when I right click on the desktop, click on New, and select WinZip File, this feature produces the error, "Unable to Create the 'New WinZip File'. The configuration registry key is invalid." It lets me create a new file on the desktop this one time, but when I right click the desktop and click on New, 'WinZip File' is no longer there as an option. Does anybody know why I keep getting this error?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hi Fly:

I believe a dll registration is not captured while taking snapshot of winzip i assume its WZSHLSTB.DLL just chek in your package whether this file exists or not?.
Answered 09/03/2005 by: wiseapp
Second Degree Green Belt

Please log in to comment
0
Thanks Bhupesh. The DLL you mention is in the package but when I try to manually register it (after installing my package) with regsvr32.exe I get the error 'c:\program files\winzip\wzshlstb.dll was loaded but the DLLRegisterServer entry point was not found. This file cannot be registered.' I have tried registering all the DLL's in the Winzip folder and I get the same error.
Answered 09/03/2005 by: the.fly
Senior Yellow Belt

Please log in to comment
0
Hi Fly:

Which capturing method have you selected in Wise Package Studio Snapshot or Smartmonitor, I should suggest a snapshot again with both the options selected that is use snapshot in conjuction with smartmonitor since there is a dll or a resource which is missing out.
Answered 09/03/2005 by: wiseapp
Second Degree Green Belt

Please log in to comment
0
I used Snapshot with SmartMonitor with Wise Package Studio. As a workaround, I tried using Wise for Windows Installer 4.21 to snapshot WinZip 9.0 and it worked perfectly! I think I amy just use this product for now instead.
Answered 09/03/2005 by: the.fly
Senior Yellow Belt

Please log in to comment
0
Hi Fly:

Good to hear that the stalemate was resolved, however even if you try the same with Wise 5.2 with snapshot and smartmonitor on it will give you the same results. Try it though. Anyways congrats once again[;)]
Answered 09/04/2005 by: wiseapp
Second Degree Green Belt

Please log in to comment
0
Hi everyone, I have one problem with WinZip 9.0 - SR1. I STFW, MSDN etc. and didn´t find solution. I repackaged WinZip, installed via GP and tested it. And here is the problem:

When the .doc, .txt etc. file are within the archive, everything works fine, BUT when the archive contains other archive (on .zip, .cab detected) it shows me this error:
[url=http://img205.imageshack.us/my.php?image=wz7iz.jpg][img=http://img205.imageshack.us/img205/9185/wz7iz.th.jpg][/url]

Could someone help me? I tried a lot of things to repair this error, but I didn´t notice something mostly.

WinZip is deployed in the company network, clients are running WinXP SP2 + latest updates.

edit:With technical support of WinZip Computing Inc. we solved this problem by this steps:

Start WinZip and then click WinZip's Options, Configuration menu item.
In the resulting Configuration dialog, click the System tab, and CHECK
the checkbox labeled Associate WinZip with archives, and then click OK.
If this checkbox is already checked, UNcheck it, click OK, and then
click the Options, Configuration menu item again, and in the System tag,
now CHECK the checkbox, and click OK.

So now I need advice how to make these steps in the installation package using table editor. Thanks for any advice :-)
Answered 02/09/2006 by: [CZ]Charlie
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity