Hi,

I have repackaged application McAffe Desktop firewall 8.0. The application work fine, only problem is the Auto Update functionality in the application does not function at all, but once i REBOOT the machine and try the same functionality it works fine.

In brief i have to restart my machine twice, once for complete installation of my application and second to make the Auto Update functionality work.
Can anyone let me know the reason for this...

If anyone has successfully repackaged this application before...Plz help me.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
charan... what packager are you using? do you think you can just use the vendor installer and just use parameters and commandlines to control it? then add some configurations after the installation... I noticed that you are having a lot of problems with this application.

I have repackaged hundreds of softwares before and not all of them can be repackaged as expected (i.e. MS Office, OutLook, Project, NOrtel, ActivClient and many more).. if I see that I am hitting the wall, I don't waste my time for it and instead, I just used the original installer.

As an SOP, consult the vendor website first for some white papers and documentations before proceeding with your packaging..

Hope this help though[;)]...
Answered 04/13/2005 by: dj_xest
Fifth Degree Black Belt

Please log in to comment
0
Hey thanks for taking time to answer my query..

I'll explain u my exact problem..

My source (McAfee Desktp firewall) to be repackaged is a VBscript. The script calls some exe's and does some custom things silently. Once installation is done, a dialog appears asking for REBOOT. I tried to check %temp% folder while running setup, theres no MSI, except for a Setup Launcher. Can u recall from ur packaging experience, could this application be successfully MSI ed. If no, just send me some link supporting the same...

My only problem is when the concerned feature in the source works fine, why does it fail in my MSI and what exactly happens when i Reboot my machine second time that makes my feature work.. It's really bamboozing me..

Could this be any way related to ini files..

I am in crunch situation, I have to give some supporting reason if i am not able to package the application.. Plz help me out..
Answered 04/13/2005 by: charan
Orange Belt

Please log in to comment
0
Charan please post your script and complete details of what you are trying to do and how will you distribute it.. Someone could be able to help you.

BTW, check this site for the install guide..

http://www.nl.noxs.com/McAfee-Product-handleidingen.html
Answered 04/13/2005 by: dj_xest
Fifth Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity