Hi,


I am having a problem with my repackaged application "Rational RequisitePro ver. 2002.05.20". The packaged msi when run works fine for all shortcuts.. except for one shortcut - "RequisitePro" ( i.e Reqisitepro.exe ). When this shortcut is clicked a message window appears saying

" Unable to open license manager (Licensing.dll) to obtain a valid license.Make sure RequisitePro is properly installed and try again."
Reason: Exception occurred
(HRESULT DISP_E_EXCEPTION) Could not checkout license.


If suppose i perform some operation ( Like opening Internet Explorer or a windows search for a file) before i launch the shortcut RequisitePro, the shortcut works consistently then on. Can anyone let me know the reason why my application doesn't work for the first time...

I tried resvr32 on licensing.dll, it is a selfregistering dll

It's very urgent plz help...
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
can you check weather any .lic file is missed out in ur repackaged application.
some times after launching the shortcut it will be created in runtime.
how abt the licesence supplied is for single user or group users?
Answered 04/03/2005 by: venki_msi
Senior Yellow Belt

Please log in to comment
0
Hey thanks for reply..

I got it resolved..

Actually i captured the installation on a dell PC and tested .msi on compaq
I don understand the diff, but it worked
Answered 04/05/2005 by: charan
Orange Belt

Please log in to comment
0
the reason might be it may create a licesence entry depending up on harware on the computer.
Did u compare the difference of both the capture of dell and compaq machine
it will tell you the clear pictuer or
using windiff tool u can find the diffrence of your installdir folder will clearly highlight any variation in your file.
Answered 04/05/2005 by: venki_msi
Senior Yellow Belt

Please log in to comment
0
thanks for details
Answered 04/05/2005 by: charan
Orange Belt

Please log in to comment
0
Hi, all

I am trying to create transform for application "VisualAge For Java for windows Ver. 3.5". It has a setup wrapped vendor msi.. The original msi did not have a keypath assigned to any of it's components. When i try to set a keypath for any of the component in my transform and run it, i get a msg "Internal Error 2707 . Dir28" . Dir28 is my INSTALLDIR.

Any idea why this is happening plz let me know..

Thanks in advance..
Answered 04/06/2005 by: charan
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity