I tried to created a Ldap label as below:





This is my Active Directory Screenshot:



I am not getting the desired output in labels.:






Currently all the computer are getting listed under this label.Why?

Do i need to correct Base DN:/Advanced Search in LDAP Label Detail?.

I want all the laptops under the particular path in AD to get listed:
OU=LAPTOPS,OU=IN,OU=COMPUTERS,OU=_NEW_AD,DC=dmx,DC=local


i have also tried to give "Base DN:DC=dmx,DC=local"and Advanced Search:"(&(objectclass=computer)(|(distinguishedName=CN=KBOX_COMPUTER_NAME,OU=LAPTOPS,OU=IN,OU=COMPUTERS,OU=_NEW_AD,DC=dmx,DC=local)))"

Testing LDAP Label Settings...
Testing "LTPINDIA" connection to: 192.168.50.29 on Port: 389
OK: Connection Successful.
OK: Setting Protocol Version 3 Successful.
OK: Setting LDAP REFERRALS Option 0 Successful.
OK: Search Bind using LDAP supplied credentials Successful.
Applying search filter [(&(objectclass=computer)(|(distinguishedName=CN=KBOX_COMPUTER_NAME,OU=LAPTOPS,OU=IN,OU=COMPUTERS,OU=_NEW_AD,DC=dmx,DC=local)))]
OK: LDAP search (with filter [(&(objectclass=computer)(|(distinguishedName=CN=KBOX_COMPUTER_NAME,OU=LAPTOPS,OU=IN,OU=COMPUTERS,OU=_NEW_AD,DC=dmx,DC=local)))]) Successful.
Error: LDAP search failed. No entries found.
Error: LDAP Test Failed. Closing connection.


4 Comments   [ + ] Show Comments

Comments

  • i have tried it and it is not working
  • i have tried it and it is not working
  • Testing LDAP Label Settings...
    Testing "India_LTP_LDAP" connection to: 192.168.50.29 on Port: 389
    OK: Connection Successful.
    OK: Setting Protocol Version 3 Successful.
    OK: Setting LDAP REFERRALS Option 0 Successful.
    OK: Search Bind using LDAP supplied credentials Successful.
    Applying search filter [(name=KBOX_COMPUTER_NAME)]
    OK: LDAP search (with filter [(name=KBOX_COMPUTER_NAME)]) Successful.
    Error: LDAP search failed. No entries found.
    Error: LDAP Test Failed. Closing connection.
  • creativegenius,

    Can you come to this week's Open Forum KKE, where we can discuss this topic, and I can show you an example of a working LDAP label in my environment? The registration link can be found here (at the bottom of the page):

    https://support.software.dell.com/k1000-systems-management-appliance/training/154/kace-kontinuing-education

    Ron Colson
    KACE Koach
    • I am troubleshooting this issue in a customer environment .i have a lab setup at my office .can you help me out with my office setup?
Please log in to comment

Answers

1
creativegenius,

Try adding the (name=KBOX_COMPUTER_NAME) key to your Advanced Search.  You can find this tip in the K1000 Admin Guide.  We've also covered it in our LDAP-related KKEs.  Here's a link to one of them:  KACE Kontinuing Education (KKE) Recording: KACE & LDAP - Maximizing the Relationship (157969)

Ron Colson
KACE Koach
Answered 03/18/2016 by: ronco
Second Degree Brown Belt

Please log in to comment
Answer this question or Comment on this question for clarity