Hi,

I am having a proble packaging "Adobe Contribute 4" I have added a property "ISX_SERIALNUMBER=XXXX-XXXX-XXXX-XXXX" for the Serial number which I read how to do here in the forum.

I also read how to do a base install and the then capture the four "MLF" files in "Allusers\Appdata\Adobe\Lincensing"

When I add these four files to my MST the pacakge will lock up.

I am using "Wise Package Studio Pro 7"

Anyhows...
Has anyone package this App? I need to deploy it to 20 different sites :-( (I am learning fast)

Also when I add the files it creates a cab file outside the msi and mst is there a way I can add this to the mst?

Regards

p4nts
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
when I add the files it creates a cab file outside the msi and mst is there a way I can add this to the mst?


This is by design. Remebering that the transform is effectively just a shortcut to the MSi.
Answered 02/07/2008 by: reds4eva
Second Degree Blue Belt

Please log in to comment
0
Thankyou for clearing that up I thought it did. I have to directly edit the MSI then if I want just a MSI and MST.
Answered 02/07/2008 by: p4ntb0y
Orange Belt

Please log in to comment
0
G'Day,

Have you checked out some of my posts on Adobe. I would say that you have some licensing issues.
Are you certain that you have a multi user license?
Also the licensing files should be application.xml (for the Adobe app your dealing with), caps.db, pcd.db and cache.db, the flexnet license file is also required but is not essential on what size or date stamp; it just has to exist on the target.
Install the vanilla version off the cd, grab these files and place them in thier respective directories in your transform (remove the existing ones first out of your transform).

BTW check your setup for the media, if you want internal cabs or external. We use uncompressed here for easy changes and updates.

Regards
Wayne
Answered 02/07/2008 by: WayneB
Blue Belt

Please log in to comment
0
Thanks for the reply but I think your thinking of Adobe Contribute 4.1 (CS3) Which use's the good old xml files. (However I could be wrong)

I had 1 exe which I extracted to produce my MSI.

I installed the app and found that it creates the files.....

Activation.mlf
Registration.mlf

in %Allusers%\Application Data

Adobe.....
Licensing
Licenses.....
Contribute 4.0....Activation.mlf
Registration.mlf
Products....
Contribute 4.0...License.mlf

I have a 20 User License from Adobe so I assume I have the enterprise version.

WayneB I am going to check out your posts as I do have to do the 4.1 next :-(

I sure I be posting a loads of threads as we are going thru a Refresh and have nothing packaged up.

I just been sent on the Wise Studio 7 course in London UK so now I meant to know it all :-( man it makes me relize how little I know the more I learn
Answered 02/07/2008 by: p4ntb0y
Orange Belt

Please log in to comment
0
G'Day,

I wasn't aware there was a difference between Ct 4.0 standalone and the CS3 version. We have separated all the CS3 apps anyway so that we could configure them to our environment.
The updates were added by doing a snap on the working install and replacing each individual file with the one supplied in the update. Thus our version of Adobe Contribute is 4.1.

We just finished the Adobe Production Premium Suite using our breakdown method. A few issues, but once nutted out we have a working configurable Suite including updates.

I hope I'm not losing it[8|]. So many apps, it's a bit of a blurr

Regards
Wayne
Answered 02/07/2008 by: WayneB
Blue Belt

Please log in to comment
0
Update.
I created a Transform instead of going thru a project and captured....

The Activation.mlf
Registration.mlf
and License.mlf

from All Users\AppData

Made my other changes and then complied, its all working fine now.

This was actually quite easy shame Adobe gone to XML based now :-(
Answered 02/21/2008 by: p4ntb0y
Orange Belt

Please log in to comment
0
Hi Wayne,

I'm sorry but I'm pretty much a noob at this, all I've done is assign msi files with group policy. I like the simplicity but I'm having a much harder time with Contribute CS3. I appreciate the clues in your post, however, would you be able to point me in the direction of a more comprehensive guide to deploying Contribute CS3 via Group Policy?
Answered 04/29/2008 by: GergMeister
Yellow Belt

Please log in to comment
0
I beleive quote me if I am wrong but the CS3 suite lincence activation is held on track 0 of the hard drive.

I have created a SMS package to deploy and the user will stil have to activate the product by telephone or the net.

If can deploy each app spearately but you have to be good at re-packaging or its going to take you a long time.

Maybe create a custom action thats starts the progam and then activates over the net?

Have a look at the adobe forums for some pointers lots of very un happy people with the adobe installer.
Answered 04/29/2008 by: p4ntb0y
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity