I am trying to deploy QT765 to Windows XP/77 users via sccm/sp2. I took the following step to customize;

- Downloaded the installer
- Extracted msi from temp directory
- Customized msi using Orca and created a mst by following instructions from sabbat, elmiko, and
damntech for Deploying Quicktime 7.5 below
( * Launch QuickTimeInstaller.exe, and wait for the fist user input screen.
* Copy the complete MSI file from %TEMP%\something. Just search for QuickTime.MSI. Copy this to a clean directory somewhere else.
* Use your favorite MSI editor (mine's ORCA, from the MS Office Support Tools) to create the mst file. Change these values...
- Property - QT_TRAY_ICON = 0
- CheckBox - ChkOptInstASU = 0
* Save the MST, then install by running "msiexec /i QuickTime.msi TRANSFORMS=Qucktime.mst /qn"

You can log the installation by adding the "/log C:\temp\quicktime.log" to the end of the msiexec command. There will be an error "The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2769. The arguments are: AddDesktopShortcuts, 1", disregard.
(Above Entry Provided on 8/11/2008 by sabbat)
Sabbat's instructions above worked for me, except they didn't get rid of the tray icon. In order to remove it, remove the qttask.exe line from the Component, FeatureComponents, and File tables when building your transform.
Above Entry Provided on 8/18/2008 by elmiko
I followed sabbats notes to the T and it got me very close. Elmikos suggestions got me a little closer. I am using Orca so I searched for any row with QTTask.exe and dropped it this removed QTTask and that got me a clean install msi.
Above Entry Provided on 8/21/2008 by damntech

- Created a batch file (msiexec /i \\server\share\QuickTime765\QuickTime.msi TRANSFORMS=QuickTime.mst /qn)
However, when I try to run this batch file on a machine, I get windows Installer error saying “Error applying transforms. Verify that the specified transform paths are valid”
Also, sccm advertisement fails with the status message below

“Windows Installer per-user elevation of this program ("S01000DE" - "Apple QuickTime 765") failed for advertisement "S0120095". The operating system reported error 1624: Error applying transforms. Verify that the specified transform paths are valid. This program was started. Please check the status of this program to determine whether or not it was completed sucessfully Possible causes: The version of Windows Installer on the computer is less than version 2.0, or the setup program does not support Windows Installer per-user elevated rights installations. Possible solutions: Update the version of Windows Installer on the computer to version 2.0 or later, or contact the software vendor that supplied the install program to determine if a version of setup that supports per-user elevated rights is available.”

What could I be doing wrong???
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


In my experience, SCCM really doesn't like per-user installs. Try it per-machine (which, if memory serves, the QuickTime license requires anyway).
Answered 12/14/2009 by: VBScab
Red Belt

Please log in to comment
After some hair pulling, I decided to look at it again and realized that I had a typo in my batch file. The word should be ‘TRANSFORM’ not ‘TRANSFORMS’. It helped me install the file locally but only after I removed /qn from the command line. I also had to accept EULA, uncheck ‘install desktop shortcuts’ and confirm Destination folder (although all of this already had been specified in MST). So I am thinking my *.mst may be corrupt.
You have a point but all previous QT packages didn’t really say not to use SCCM. I wonder if there is something different in QT765. If this doesn’t work out in SCCM, GPO may be another option for me.
Answered 12/14/2009 by: tkhan
Yellow Belt

Please log in to comment
The word should be ‘TRANSFORM’ not ‘TRANSFORMS’Of course, you meant the other way around. Well, according to certain sources, anyway :)
Answered 12/15/2009 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity