My issue is as follows which is to do with the Quicktime preferences.
I am installing Quicktime 7.6.4 and I start off simply by extracting the quicktime.msi and also AppleApplicationSupport.msi.
I deploy both of these via:
msiexec /i sourcedir\QuickTime.msi /qb
msiexec /i sourcedir\AppleApplicationSupport.msi /qb
as Quicktime.msi relies on Apple Application Support being installed.

My issue is that logged in as a privileged user, I can go to Edit Preferences and Quicktime Preferences and Streaming and Enable Instant On is ticked and also Edit Preferences and Quicktime Preferences and File Types, I can tick any of the boxes.

This allows me to run Streaming movies such as Apple sample movies for example via IE as a privileged user.
Now when I login as an unprivileged user, when he goes into Preferences and File Types as above, it says Programmatically set and I can't see any of the boxes to tick.
Also, for Streaming Enable Instant On is unticked and greyed out.
The end result is that unprivileged users cannot play any streaming Quicktime movies via IE or Firefox.
If I make the same unprivileged user a local administrator of the PC, there is no issue.

My guess is that it is needing access to the preferences file in either C:\Documents and Settings\Administrator or C:\Documents and Settings\All users.

Note: I have installed Quicktime with a privileged user account and made changes to Preferences, then copied C:\Documents and Settings\logged in privileged user\Local Settings\Application Data\Apple Computer\QuickTime\QuickTime.qtp and also copied C:\Documents and Settings\All Users\Application Data\Apple Computer\QuickTime\

Then I login as an unprivileged user and copy QuickTime.qtp from above to
C:\Documents and Settings\unprivileged user account\Local Settings\Application Data\Apple Computer\QuickTime\QuickTime.qtp. Problem exists.

How do I resolve this issue with Quicktime for non-privileged user accounts?

0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


stop using qt? seriously, the product sucks and the install does too.
but if you have to use it, try running procmon/filemon/regmon to find where it's trying to access during the time when the options are greyed out. it's my understanding that most options are under the user profile though.
Answered 09/24/2009 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
Here are the notes I made for our package of Quicktime 7.64:

--QuickTime.qtp file placed in the AllUsers directory on install.
--HKLM\Software\Apple Computer, Inc.\QuickTime\SystemPreferences\ written to on install.
--QTPlayersession.xml file placed in [LocalAppDataFolder] on profile fix.
--HKCU\Software\Apple Computer, Inc.\QuickTime\LocalUserPreferences\ written to on profile fix.
--AppleApplicationSupport.msi and .mst included for Quicktime and iTunes requirements.

From my other notes(these are the keys that are written on install(HKLM) and the profile fix(HKCU):

[HKEY_CURRENT_USER\Software\Apple Computer, Inc.\QuickTime\LocalUserPreferences]
"FolderPath"="C:\\\\Documents and Settings\\\\All Users\\\\Application Data\\\\Apple Computer\\\\QuickTime\\\\"

[HKEY_LOCAL_MACHINE\Software\Apple Computer, Inc.\QuickTime\SystemPreferences]
"FolderPath"="C:\\\\Documents and Settings\\\\All Users\\\\Application Data\\\\Apple Computer\\\\QuickTime\\\\"

So place the files where they need to go... .qtp to the AllUsers, .xml to local user profile...write the keys, and be done with it. Profile fix works, but I guess one could do activesetup also.

Same formula as 7.5 and 7.6....unfortunately 7.64 is required for iTunes 9.0...and both require AppleApplicationSupport.msi.

Owen is right though, QT as a enterprise deploy sucks. Its strange that Apple wants infiltration into .edu's with Quicktime and iTunes and yet they make it such a pain to install globally.
Answered 09/25/2009 by: mikesyr
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity