I changed the QuickTime 7.1 vendor MSI to deploy it in silent mode.
Now I would like to customize the vendor MSI with with user specific configurations (like MIME types, quicktime.qtp [sorry I mean QTPlayerSession.xml] in the profile...).
The problem now is: That these user configurations aren't written in some cases. If a user hasn't any special rights the quciktime.qtp [sorry I mean QTPlayerSession.xml] and the user specific registry are written successful (I think this is the self-healing or advertisement process,.. I'm not shure).
If an user has administrative privileges only the registry part is reinstalled but the quicktime.qtp [sorry I mean QTPlayerSession.xml] file isn't installed in the users profile. I tried to change the feature properties to "advertised". But this didn't take any effect. Why can't I get the quicktime.qtp [sorry I mean QTPlayerSession.xml] file reinstalled under an user with administrative privileges?

We use InstallShield Professional out of the AdminStudio 11.5

Can anybody help me, please?

Thanx

hafen
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
hafen,

you'll have to use a Set Directory custom action to point the directory to "%APPDATA%\Apple Computer\QuickTime"
Answered 07/28/2006 by: AngelD
Red Belt

Please log in to comment
0
Hi hafen,
don't know how you manage this behavior. The file quicktime.qtp isn't installed at all with the QT-MSI. However, it is created in the AllUsers profile, when you start QT for the first time.
If you want to install that file with your settings, you have to to it on your own.
Regards, Nick
Answered 07/29/2006 by: nheim
Tenth Degree Black Belt

Please log in to comment
0
Thank you all for your posts...

First I would describe how I had it done.
I took the original MSI from Apple and installed it. After that I made a snapshot before I first time started Quicktime. Than I configured Quicktime in the way we would like to distribute it. The after snapshot showed me all the registry parts and files that are installed and registered on the first run of Quicktime.
Final I took all these components out of this new "settings-MSI" into the original MSI from Apple. I stored these components under the feature "QuickTimeEssentials" in the MSI. The shortcut property "Advertised" I changed to "Yes" (Quicktime shortcut in Program Menu).

The problem now is not like I have mentioned before the Quicktime.qtp (this file is installed under the %AllUsersProfile%\Application Data\Apple Computer\Quicktime). The poroblem is the QTPlayerSession.xml which is installed under "%UsersProfile%\Application Data\Apple Computer\Quicktime" (Sorry). This file won't be installed if a user has administrative privileges. With user accounts that have no administrative privileges it works (the QTPlayerSession.xml is installed/reinstalled/repaired ?).
At the beginning there was the same problem with the user specific registry keys. After I changed the "Remote Installation" property to "Favor Source" (in InstallShield Professional) and this solved the problem. But on the component with the file QTPlayerSession.xml this "trick" doesn't work, because the file isn't installed anymore.
I also tried to change the "Advertised" property of the feature "QuickTimeEssentials" to "Allow Advertise". But this didnt't take any effect (I think the original MSI from Apple is special in this case).
On Friday I tried the hint from AngelD (with QTPlayerSession.xml instead of QuickTime.qtp). But the problem persist still.

I can't understand why the file "QTPlayerSession.xml" won't be reinstalled if a user has administrative privileges.

Best regards

hafen
Answered 07/31/2006 by: hafen
Senior Yellow Belt

Please log in to comment
0
Hi hafen,

this is a common scenarion when the component has a file set as key point, you will need to set a HKCU registry as key point for the component (holding the "QTPlayerSession.xml") to resolve this.

The "problem" with userprofiles is that administrators has read access to other userprofiles and will find the file and think it's installed under the admin profile.

Hope that helps
Answered 07/31/2006 by: AngelD
Red Belt

Please log in to comment
0
Just to inform why registry will work instead of file key path; only logged in users HKCU registry hive will be loaded, so by setting a registry as key path to make sure that any user with administrative rights cannot find other users registry info as they are not loaded only the current users registry.

By setting a file as key path for a component containing userprofile data Windows Installer engine will search through every profile it finds and try to locate the key path. If no user has the key path for the component the component will be installed.

Cheers!
Answered 07/31/2006 by: AngelD
Red Belt

Please log in to comment
0
Many thanks. This solved my problem.

I have created within the component of QTPlayerSession.xml a string registry entry in HKCU. With this registry value I track the installation of the QTPlayerSession.xml.
Now it works [:)]

Best regards

hafen
Answered 07/31/2006 by: hafen
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity