This is what I do:
I start to install the offline Exe-file, I grab the MSI-file (include cab-file) and deploy it. I get no errors and Java works well when I check it on the "Validate page".

The problem starts when I try to open Java from Control Panel. Nothing happends and when I look at the logs, it says something with : No user found. I then uninstall it with an admin login (account) and Java dissapears both from Control Panel and Installed softwares. After uninstall I log in as normal user and I can see Java in both Control Panel and Installed programs. When I try to open Java, it says something with: Cant find....

So I need to restore Win 7 to an earlier restore point.

If I run the MSI file localy in CMD as admin the installation goes 100% perfect and I can open Java. The difference is that SCCM 2012 uses the system account and when I install it, It runs on my account.

I really dont know what the problem is. Im at home right now and dont have any more details to give, but can surely answer with more details tomorrow from work.


7 Comments   [ + ] Show Comments


  • Can you please post the command(s) you are using to install the package?
  • >The difference is that SCCM 2012 uses the system account and when I install it, It runs on my account.
    It *sounds* to me like you have some user-level component in there and, when installing with System, it's getting written to the System account's profile.

    What did you specify for the ALLUSERS property? Also, as ever, a verbose log of the install is worth taking.
  • Yes, please create a verbose logfile with using /L*v <path\logfilename>. It will show you not only the failure reason, but will list all features and MSI properties to great detail. You definitely want that if you're a true packager. :-)

    To the topic: check logfile for ALLUSERS properties. If its "2", you installed it only for the current user. In case of SCCM that's, as VBScab already said, the SYSTEM user. Please use ALLUSERS=1 in your command line.
  • I used:
    msiexec /i "jre1.7.0_21.msi" /qn AUTOUPDATECHECK=0 JAVAUPDATE=0 JU=0 EULA=0
  • I did have earlier a logile when I tryed to deploy the EXE-file but the Log was empty. How ever I did found a solution in our environment, post it in a new Comment...
  • I found that I need to install au.msi (updater) to make it work. I also had to deploy both Exe-file and the MSI file so this is how my cmd-file looks like:

    msiexec /i "au.msi" /qn

    start /wait jre-7u21-windows-i586.exe /s /v"/norestart AUTOUPDATECHECK=0 JAVAUPDATE=0 JU=0 EULA=0"

    msiexec /i "jre1.7.0_21.msi" /qn AUTOUPDATECHECK=0 JAVAUPDATE=0 JU=0 EULA=0

    REM Disable Java Update Tab and also Updates and Notifications
    reg add "HKLM\SOFTWARE\Wow6432Node\JavaSoft\Java Update\Policy" /v EnableJavaUpdate /t REG_DWORD /d 00000000 /f
    reg add "HKLM\SOFTWARE\Wow6432Node\JavaSoft\Java Update\Policy" /v NotifyDownload /t REG_DWORD /d 00000000 /f
  • I guess my solution is not a good looking one but It works. I also guess that the correct solution is to use ALLUSERS=1. My question is:
    Can I use the ALLUSER=1 property (in my command line) in both MSI deploy or EXE deploy?
Please log in to comment

There are no answers at this time


Answer this question or Comment on this question for clarity