Dear,

 

I'm having problems installing a software on 5-6 pc's. It installs well on all other computers. The machines where it fails are Win7 and WinXP.

In the log file I have the following:

KDEPLOY.log:

[Tue Mar 26 17:08:42 2013] KDeploy    ----- Starting KDeploy.exe -----
[Tue Mar 26 17:08:42 2013] KDeploy called with params: -custominventory
[Tue Mar 26 17:08:42 2013] KDeploy    custominventory processing 0 rules
[Tue Mar 26 17:08:42 2013] KDeploy    finished processing 0 custominventory rules, sending response
[Tue Mar 26 17:09:02 2013] KDeploy    ----- Starting KDeploy.exe -----
[Tue Mar 26 17:09:02 2013] KDeploy called with params: -fs -mi -fade=1 -notifyevent=
[Tue Mar 26 17:09:02 2013] KDeploy    Fetching MI & FS info from server
[Tue Mar 26 17:09:03 2013] Local hash of file matches
[Tue Mar 26 17:09:03 2013]     DLPkgFrmKBOXtoKaceDLdir: BONUS! File already exists locally [C:\Documents and Settings\All Users\Dell\KACE\downloads\4541\BizAgiPMSetup.exe], exit 1
[Tue Mar 26 17:09:03 2013] Local hash of file matches
[Tue Mar 26 17:09:03 2013] KLaunch    Flags/Cmd/Args: ". -timeout 3540000 -workingdir "C:\Documents and Settings\All Users\Dell\KACE\downloads\4541" C:\Documents and Settings\All Users\Dell\KACE\downloads\4541\BizAgiPMSetup.exe /S /f1"C:\BizAgiPMSetup.iss""
[Tue Mar 26 17:09:03 2013] KLaunch    Initiating local execute...
[Tue Mar 26 17:09:03 2013] KLaunch    Locally exec "C:\Documents and Settings\All Users\Dell\KACE\downloads\4541\BizAgiPMSetup.exe"
[Tue Mar 26 17:09:03 2013] KLaunch    WaitNamedPipe for StdOut Pipe \\.\pipe\KLaunch_V1_StdOutTGLZWAALR26104
[Tue Mar 26 17:09:03 2013] KLaunch    Start of ExecuteThread
[Tue Mar 26 17:09:03 2013] KLaunch    WaitNamedPipe couldn't find StdOut Pipe \\.\pipe\KLaunch_V1_StdOutTGLZWAALR26104: (2) The system cannot find the file specified.


[Tue Mar 26 17:09:03 2013] KLaunch    Command="C:\Documents and Settings\All Users\Dell\KACE\downloads\4541\BizAgiPMSetup.exe" Args="/S /f1"C:\BizAgiPMSetup.iss"" WorkingDir="C:\Documents and Settings\All Users\Dell\KACE\downloads\4541" Machine="TGLZWAALR2" UserName="" Domain="" Password=XXXX Priority=32 ProcessId=6104 Timeout=3540000 NoWait=0 KeepAlive=0 Interactive=0 Hide=0 NoStdio=0
[Tue Mar 26 17:09:03 2013] KLaunch    WaitNamedPipe for StdErr Pipe \\.\pipe\KLaunch_V1_StdErrTGLZWAALR26104
[Tue Mar 26 17:09:03 2013] KLaunch    *CreateNamedPipe StdOut Pipe \\.\pipe\KLaunch_V1_StdOutTGLZWAALR26104
[Tue Mar 26 17:09:03 2013] KLaunch    WaitNamedPipe couldn't find StdErr Pipe \\.\pipe\KLaunch_V1_StdErrTGLZWAALR26104: (2) The system cannot find the file specified.


[Tue Mar 26 17:09:03 2013] KLaunch    *CreateNamedPipe StdErr Pipe \\.\pipe\KLaunch_V1_StdErrTGLZWAALR26104
[Tue Mar 26 17:09:03 2013] KLaunch    Don't WaitNamedPipe for StdIn Pipe (disabled)
[Tue Mar 26 17:09:03 2013] KLaunch    *Don't CreateNamedPipe StdIn Pipe (disabled)
[Tue Mar 26 17:09:03 2013] KLaunch    Pass 1 of 5 Timed out. Wait 1000 ms and try again.
[Tue Mar 26 17:09:03 2013] KLaunch    *ConnectNamedPipe StdOut Pipe \\.\pipe\KLaunch_V1_StdOutTGLZWAALR26104
[Tue Mar 26 17:09:04 2013] KLaunch    WaitNamedPipe for StdOut Pipe \\.\pipe\KLaunch_V1_StdOutTGLZWAALR26104
[Tue Mar 26 17:09:04 2013] KLaunch    CreateFile StdOut Pipe \\.\pipe\KLaunch_V1_StdOutTGLZWAALR26104
[Tue Mar 26 17:09:04 2013] KLaunch    *ConnectNamedPipe StdErr Pipe \\.\pipe\KLaunch_V1_StdErrTGLZWAALR26104
[Tue Mar 26 17:09:04 2013] KLaunch    WaitNamedPipe for StdErr Pipe \\.\pipe\KLaunch_V1_StdErrTGLZWAALR26104
[Tue Mar 26 17:09:04 2013] KLaunch    CreateFile StdErr Pipe \\.\pipe\KLaunch_V1_StdErrTGLZWAALR26104
[Tue Mar 26 17:09:04 2013] KLaunch    Client start stdio redirection listen threads.
[Tue Mar 26 17:09:04 2013] haveTokenLsaPriv returning: 1
[Tue Mar 26 17:09:04 2013] KLaunch    Start of ListenStdOut thread
sful
[Tue Mar 26 17:09:04 2013] KLaunch    Start of ListenStdErr thread
[Tue Mar 26 17:09:04 2013] KLaunch    ExecuteAsCurrentUserOnDesktop
[Tue Mar 26 17:09:04 2013] searchPath='C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\system32\WindowsPowerShell\v1.0;C:\Program Files\Intel\DMIX;c:\Program Files\Intel\WiFi\bin\;C:\Program Files\NTRU Cryptosystems\NTRU TCG Software Stack\bin\;C:\Program Files\Wave Systems Corp\Gemalto\Access Client\v5\;c:\Program Files\Common Files\Roxio Shared\DLLShared\;c:\Program Files\Common Files\Roxio Shared\10.0\DLLShared\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\' envPath='C:\Documents and Settings\All Users\Dell\KACE\downloads\4541' tempPath=''
[Tue Mar 26 17:09:04 2013] KLaunch    Run as current user "SYSTEM"
[Tue Mar 26 17:09:04 2013] KLaunch- CreateProcessWithEnv with Token
[Tue Mar 26 17:09:04 2013] KLaunch    Run as user "NT AUTHORITY\SYSTEM"
[Tue Mar 26 17:09:04 2013] haveTokenLsaPriv returning: 1
[Tue Mar 26 17:09:04 2013] KLaunch    Execute command=[C:\Documents and Settings\All Users\Dell\KACE\downloads\4541\BizAgiPMSetup.exe] args=[/S /f1"C:\BizAgiPMSetup.iss"]
[Tue Mar 26 17:09:04 2013] searchPath='C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\system32\WindowsPowerShell\v1.0;C:\Program Files\Intel\DMIX;c:\Program Files\Intel\WiFi\bin\;C:\Program Files\NTRU Cryptosystems\NTRU TCG Software Stack\bin\;C:\Program Files\Wave Systems Corp\Gemalto\Access Client\v5\;c:\Program Files\Common Files\Roxio Shared\DLLShared\;c:\Program Files\Common Files\Roxio Shared\10.0\DLLShared\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\' envPath='C:\Documents and Settings\All Users\Dell\KACE\downloads\4541' tempPath=''
[Tue Mar 26 17:09:04 2013] searchPath='C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\system32\WindowsPowerShell\v1.0;C:\Program Files\Intel\DMIX;c:\Program Files\Intel\WiFi\bin\;C:\Program Files\NTRU Cryptosystems\NTRU TCG Software Stack\bin\;C:\Program Files\Wave Systems Corp\Gemalto\Access Client\v5\;c:\Program Files\Common Files\Roxio Shared\DLLShared\;c:\Program Files\Common Files\Roxio Shared\10.0\DLLShared\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\' envPath='C:\Documents and Settings\All Users\Dell\KACE\downloads\4541\C:\Documents and Settings\All Users\Dell\KACE\downloads\4541\BizAgiPMSetup.exe' tempPath=''
[Tue Mar 26 17:09:04 2013] searchPath='C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\system32\WindowsPowerShell\v1.0;C:\Program Files\Intel\DMIX;c:\Program Files\Intel\WiFi\bin\;C:\Program Files\NTRU Cryptosystems\NTRU TCG Software Stack\bin\;C:\Program Files\Wave Systems Corp\Gemalto\Access Client\v5\;c:\Program Files\Common Files\Roxio Shared\DLLShared\;c:\Program Files\Common Files\Roxio Shared\10.0\DLLShared\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\;C:\Program Files\Dell\KACE\;C:\Documents and Settings\All Users\Dell\KACE\' envPath='C:\Documents and Settings\All Users\Dell\KACE\downloads\4541\BizAgiPMSetup.exe' tempPath=''
[Tue Mar 26 17:09:04 2013] KLaunch    cmd=["C:\Documents and Settings\All Users\Dell\KACE\downloads\4541\BizAgiPMSetup.exe" /S /f1"C:\BizAgiPMSetup.iss"] path=[C:\Documents and Settings\All Users\Dell\KACE\downloads\4541]
[Tue Mar 26 17:09:04 2013] KLaunch    CreateProcessAsUser returned successfully
[Tue Mar 26 17:09:17 2013] KLaunch    End of ExecuteThread
[Tue Mar 26 17:09:18 2013] KLaunch    Local command returned -3(0xFFFFFFFD)
[Tue Mar 26 17:09:18 2013] Failed to convert the stdout/stderr content in  to UTF-8 using code page 437
[Tue Mar 26 17:09:18 2013] KDeploy    LaunchProcess: NONZERO STATUS returned by KLaunch (-3).
[Tue Mar 26 17:09:18 2013] KDeploy    Managed Install FAILED (BizAgiPMSetup.exe)
[Tue Mar 26 17:09:18 2013] KDeploy    ----- Ending KDeploy.exe -----

Klaunch.log:

[Tue Mar 26 17:09:32 2013] kbot[99:1363691589] @ 2013-03-26T17:09:32 (debug) runkbot    ----- completed [exitCode=0] -----

kbot[99:1363691589] @ 2013-03-26T17:09:32 (output) Running as: SYSTEM

kbot[99:1363691589] @ 2013-03-26T17:09:32 (output) File Info Operation success: file C:\Program Files\Dell\KACE\runkbot.exe, success=0

kbot[99:1363691589] @ 2013-03-26T17:09:32 (output) Product version runkbot.exe is not 5.3.53177 (fail)

kbot[99:1363691589] @ 2013-03-26T17:09:32 (status) FINISH (in state 'remediation_success')

Uploading Lo
[Tue Mar 26 17:09:32 2013] g file [C:\WINDOWS\TEMP\dkl144.tmp]


[Tue Mar 26 17:09:32 2013] DownloadFile: Downloaded C:\WINDOWS\TEMP\dkl145.tmp from http://tgblskace01.tgdir.thrombogenics.com/service/kbot_service_notsoap.php?METHOD=getuploadpath&KUID=1F0080C8-AD65-401F-8CE5-2215910397B5&FILENAME=KBOT_LOG.txt Download speed: 3460.000000 bytes/second


[Tue Mar 26 17:09:32 2013] UploadFile: Uploaded to http://tgblskace01.tgdir.thrombogenics.com/service/kbot_upload.php?machineId=5&filename=KBOT_LOG.txt&checksum=8fac0085b505949a648649b7cb81c7da&mac=1F0080C8-AD65-401F-8CE5-2215910397B5 Upload speed: 157750.000000 bytes/second


[Tue Mar 26 17:09:32 2013] Cleaning up log file [C:\WINDOWS\TEMP\dkl144.tmp]

 


[Tue Mar 26 17:09:32 2013] runkbot    ----- Exiting runkbot.exe -----


[Tue Mar 26 17:09:32 2013] KLaunch    End of ExecuteThread
[Tue Mar 26 17:09:32 2013] KLaunch    Local command returned 0(0x0)
[Tue Mar 26 17:09:32 2013] Failed to convert the stdout/stderr content in  to UTF-8 using code page 437
[Tue Mar 26 17:09:32 2013] KLaunch    ----- Exiting KLaunch.exe (Error 0, Status 0)-----

 

Kinventory.log:[Tue Mar 26 17:08:45 2013] KInventory   Error: InventoryData AddItem : Could not find map in 'S' for 'N'
[Tue Mar 26 17:08:45 2013] KInventory   Now gathering PhysicalMemory information...
[Tue Mar 26 17:08:45 2013] KInventory   Now gathering PhysicalMemoryArray information...
[Tue Mar 26 17:08:45 2013] KInventory   Now gathering InstalledSoftware64 information...
[Tue Mar 26 17:08:45 2013] KInventory   Now gathering InstalledSoftware32 information...
[Tue Mar 26 17:08:45 2013] KInventory   Error: InventoryData AddItem : Could not find map in 'I' for 'D'
[Tue Mar 26 17:08:45 2013] KInventory   Error: InventoryData AddItem : Could not find map in 'I' for 'D'

 

All suggestions more than welcome

 

Thanks

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

0

If it works on other XP/Win7 systems, what's different on the ones it fails on?  Most likely, either some condition or prerequisite isn't met. 

I'm not seeing much in the log.  Is debug enabled?  http://www.kace.com/support/resources/kb/article/how-to-enable-debug-logs-on-the-kace-k1000-client-kbox-client-deployment

Answered 03/26/2013 by: jknox
Red Belt

  • What happens when you navigate to %allusersprofile%\Dell\KACE\downloads and run the exe manually? Does it install?
Please log in to comment
Answer this question or Comment on this question for clarity