Hi!

Ivé repackaged Real Player 10 Gold with Wise Package Studio 5.1 and the MSI-installation works fine except for one thin.

When logged on with user permissions (package assigned) Real Player tries to check for updates when starting Real Player. A message box is displayed that says I dont have permissions to change AutoUpdate or something like that.

Does anyone know how to disable the autoUpdate function for the CURRENT_USER.
Ive tried with snapshots to record this but I think I dont actually find the right place to disable this.

Regards
Marcus Torstensson
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Have you tried granting security permissions to the registry keys under
HKEY_CLASSES_ROOT\Software\RealNetworks.

Find the registry key under this hive that requires permissions.
This will solve your problem.
Answered 12/08/2004 by: jagannath_72
Yellow Belt

Please log in to comment
0
Is there a way to change registry permissions for a group of users in an AD group? I haven't found a way to do this yet, but it would be very helpful.
Answered 12/09/2004 by: bafarmer
Yellow Belt

Please log in to comment
0
The easiest way is to use Reggrant.exe or another utility like it as a custom action in your msi.

The other way is longer and a little more complicated but works flawlessly.

You can create an inf file with your permissions in it and apply it using Secedit.exe as a custom action.
Answered 12/09/2004 by: MSIMaker
Second Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity